20

I'm a student and I'm constantly opening up PDFs for homework. I often end up downloading multiple files, after clicking on a link, each time I start working. Is there any way to set Chrome to only open PDFs and not download them?

2
  • 6
    This question was asked in the wrong community.
    – zylstra
    Aug 14, 2017 at 19:49
  • ALT+Click, To download quickly without changing the settings, you can hold the ALT key while clicking on the link. Feb 26, 2023 at 5:39

10 Answers 10

7

You will have to teach your Chrome how to Preview PDF's

For that you need to install a PDF preview "add on" in Chrome.

Automatically previews pdfs, powerpoint presentations, and other documents in Google Docs Viewer.

Or you can try this : You can normally open PDFs automatically in Chrome by clicking on the file you want to see.

If your PDFs are downloading instead of opening automatically in Chrome, Chrome PDF viewer could be turned off.

On your computer, open Chrome. At the top right, click More Settings. At the bottom, click Show advanced settings. Under “Privacy”, click Content settings. Under “PDF Documents," check the box next to "Open PDF files in the default PDF viewer application.” (Uncheck this box if you want PDFs to open automatically when you click them.)

3
  • I did both but chrome still downloads without previewing. Is there anything else I should do?
    – leon
    Jul 16, 2020 at 16:35
  • If anyone still needs help: Settings -> Privacy and Security -> Site Settings -> Additional Content Settings -> PDF Documents -> Deactivate to disable downloading files and read in Chrome
    – Ashfaq
    Apr 5, 2021 at 3:58
  • 2
    @existingperson and others: Many times a download occurs due to the file headers defined by the website developers, regardless the Chrome setting. See this answer for a workaround with "No PDF Download" extension: apple.stackexchange.com/a/437768/469990
    – Meir Cohen
    Aug 15, 2022 at 10:43
12

Go to

chrome://settings/content/pdfDocuments

and flip the switch. No add-on needed.

11

Chrome Settings

First, go to chrome://settings/content/pdfDocuments and check, that the default behavior is set to Open PDFs in Chrome.

Do you still experience Chrome to download the PDF directly?

Checking the HTTP's headers

The reason may be the HTTP Content-Disposition header. If the site admin/developer set this header to attachment (instead of inline), it tells the browser that the content should be downloaded directly.

Or maybe the HTTP Content-Type header is not set to application/pdf but instead to application/octet-stream - rendering the browser unable to automatically open the PDF, leaving it only the download option.

Workaround

There is a Chrome extension which automatically checks those headers and changes them if necessary. Enabling the browser to open those files inline.

1
  • 2
    👍Thanks for pointing out this chrome extension. Finally I get to preview all PDFs in the browser even if they are served with the "wrong" headers.
    – Daniel K.
    Nov 10, 2022 at 8:03
8

FYI This answer is outdated and no longer relevant:

Go to chrome://extensions in the address bar, then find and enable Chromium PDF Viewer.

This will tell Chrome to use its built-in PDF viewer instead of downloading. After this is enabled, to download PDFs, just press command+S.

5
  • We are looking for longer answers with more detail. Please edit your answer to provide more info, images, and/or links to credible sources.
    – Allan
    Mar 31, 2016 at 17:54
  • 4
    Why does he need to be even more specific? His answer is the best approach to this specific problem Jun 1, 2016 at 22:31
  • 4
    chrome://plugins is no longer available: bugs.chromium.org/p/chromium/issues/detail?id=615738 .
    – zylstra
    Aug 14, 2017 at 19:49
  • 2
    This site can’t be reached The webpage at chrome://plugins/ might be temporarily down or it may have moved permanently to a new web address. ERR_INVALID_URL Aug 20, 2018 at 22:19
  • 6
    Answer no longer relevant. Sep 6, 2018 at 6:18
2

In Google Chrome go to Settings. Scroll to the bottom of the page and click on the hyperlink for Show Advanced Settings. From there scroll down until you find the "Download" section. Uncheck the box where it asks where to save each file before downloading. Close Chrome and reopen. You should now be able to have the PDF open without prompting to save it.

1
  • 3
    On the newest version (44) that doesn't work. All it does is automatically save to the default location, which is the Downloads folder.
    – user139476
    Aug 7, 2015 at 16:55
2

Go to Chrome>Settings>Advanced Settings>Content Settings>PDF Documents.

Deselect the option Open PDF files in the default PDF viewer

2
  • 8
    That setting is off already. Aug 20, 2018 at 22:21
  • 1
    And now the option has changed to "Download PDF files instead of automatically opening them in Chrome" (which is already off)
    – Michael
    Nov 4, 2018 at 23:13
1

I fixed this problem by going to Chrome://extensions Because I have Adobe Acrobat installed on my computer, the extension was present, but defaulted to 'disabled'. Toggling to 'enabled' now triggers a pop-up when clicking pdf links, to 'Open in Acrobat'

1

Within Chrome, do this:

  • Chrome.app > Chrome (menu) > Preferences
  • Settings > + Show advanced settings (text link) > Content Settings (button)

Then scroll down to PDF Documents and check: Open PDF files in the default PDF viewer application application. (Uncheck this box if you want PDFs to open automatically when you click them.)

2
  • 2
    The only option available in that page is "Download PDF files instead of automatically opening them in Chrome". Sep 6, 2018 at 6:21
  • Much easier than navigating manually: going here: chrome://settings/content/pdfDocuments
    – ijoseph
    Dec 16, 2019 at 18:21
0

I don't have the "whether to save each file before downloading" question on advanced settings - only where to save the file. However - I find that if I click on a pdf and chrome asks where to save it, if I say "cancel" and then click the pdf again it simply shows it with downloading it! Hope this helps.

0

No extension needed

✅ Chrome allows this right out of the box.

Navigate to:

chrome://settings/content/pdfDocuments and select Open PDFs in Chrome.

Then, you click a hyperlink and it is STILL "downloading" instead of "opening" in chrome, the only thing you need to do is right-click and Open Link in New Tab (or New Window).

On "some" pdf links, you can use a shortcut to open a new tab: ⌘ + click the link. In my experience it doesn't always work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .