I'm copying the backup folder of Time Machine, but it's taking too long, the backup is 90GB and the copy already reports 160GB and there's 60% to go yet, so I suspect it's copying hardlinks as different "solid" versions of the files. (which would take up much more space than I have avaible, which is 300GB)

I tried making a partition of 120 GB to fit it by restoring from disk utility, but it said there wasn't enough space.

Also tried to restore to a sparse bundle on a partition with 300GB free, but didn't work either.

Is there a better or smarter way of doing this within my 300GB space?

edit & PS: The only alternative if this doesn't work is keeping only the last backup and saying bye bye to the older ones.

PS 2: Time Machine just recognized the old Backup folder and resumed from it even when the OS was freshly re-installed.

  • 1
    I have tried to copy (non-supported) TM volumes, but it always refused to continue to use the new drive. Every time I have resorted to just doing full backup to new drive and holding on to my old drive for a while, until sufficient history has built up on new drive (a week or two).
    – Laas
    May 23, 2011 at 6:09
  • @Laas — Interesting. But what do you call “non-supported” ? Oct 12, 2013 at 16:19
  • @Laas — How have you tried to copy the volumes ? With the Finder ?… Oct 12, 2013 at 16:23
  • @NicolasBarbulesco - I mean enabling unsupported network drives in TM ( j.mp/GYWCQf ).
    – Laas
    Oct 14, 2013 at 7:02

4 Answers 4


If you are using an entire drive for time machine backup, I would suggest using Carbon Copy Cloner latest version with block-to-block copy. I have seen people use Disk Utility for this but I haven't got this to work.

As noted in this answer CCC does not work for TM backups now (since BigSur?) see CCC site

  • You could use CCC even if its not a complete drive/partition. May 23, 2011 at 5:35
  • 2
    Another satisfied CCC user here.
    – boehj
    May 25, 2011 at 19:08
  • -1 for unsolicited paid software recommendation Oct 30, 2012 at 16:00
  • @BlacklightShining — “Unsolicited” ? Are you kidding ? What about these 6 paragraphs from @Petruza ? Oct 12, 2013 at 16:51
  • 1
    It's not working anymore: "CCC will exclude the Backups.backupdb folder during a backup task because Time Machine backup folders contain Apple-proprietary filesystem devices."
    – balazs630
    Apr 16, 2021 at 15:00

Use rsync. rsync is included in MacOS X, it's widely recognised in the unix world and it can be used locally and on the network and can preserve hardlinks, attributes and permissions. Check the manual page for more information, IMHO this should work:

rsync -avHE /Volumes/Source/ /Volumes/Destination/

(archive, verbose, preserve hardlinks, preserve extended attributes).

  • The version that ships with 10.6.x is 2.6.9. It's quite out of date. As I understand it, it doesn't handle resource forks correctly. I wonder if we'll see an update in 10.7.x?
    – boehj
    May 25, 2011 at 19:13
  • 1
    rsync only finds hard link files and not directories
    – mmmmmm
    Oct 10, 2014 at 21:45

Starting from January 2020, CCC is not allowing clone tasks for Time Machine volumes, see this official docs: https://bombich.com/kb/ccc5/can-i-use-carbon-copy-cloner-clone-time-machine-backup

However another application SuperDuper! does the trick. It's free for tasks like a simple clone. Make sure to select "Backup - all files" option after setting the source and destination partitions.

It took 11 hours to move 900GB of data to a new drive, but it worked really well under macOS Big Sur. I've already finished my first new backup tasks to the new drive.


Not the exact solution, but now that I reinstalled the OS, with great surprise and joy, I find that Time Machine resumes backing up with the same backup folder from before, just calculated the differences and off it went. :D
As I wasn't going to restore the full backup, none of it actually, I thought Time Machine would need to start over with an empty backup, that's why I wanted to backup the TM backup folder, but it's not needed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .