1

I'm setting up my parents' iPad (Retina, 3rd gen, iOS 8) and trying to enable iCloud backup. We've purchased enough iCloud storage space to back up everything, and I use iCloud backup on all my devices without problems so I know how it works. But after starting the initial backup, it goes through "Estimating time remaining" for a while, comes up with an estimate (usually something like 10 or 15 minutes) and then starts increasing the estimate, starting at a few minutes and going up continually until it hits several hours. The progress bar moves to a certain point (about 20%) and just hangs. I've left it sit overnight and in the morning the bar has not moved and the estimate is even higher.

I tried disabling the camera roll (the largest thing being backed up) and it completes. Enabling it and backing up again hangs in the same spot. It seems that the camera roll is causing the hang, but I don't see how to debug it.

I've tried disabling iCloud, rebooting, and reenabling, but that doesn't help. Does anyone have any ideas here?

2

Camera Roll is gone in iOS8.

It might be that you would nee the new iCloud Photo Library, part of iCloud Drive, before they will sync again.

One thing to do is to migrate any photos you might still have in iPhoto - launch it & you will be given the option - as that's gone too.

see http://www.imore.com/yes-camera-roll-gone-ios-8-heres-where-it-went-and-why
or http://appleinsider.com/articles/14/09/19/goodbye-camera-roll-where-to-find-your-photos-in-ios-8

  • 1
    I'm accepting this answer. The actual problem kind of solved by itself. For a while, Camera Roll still showed as the backup option. After unchecking it and completing a backup without the Camera Roll, it updated to show Photo Library and it backed up after that. – Justin Mrkva Sep 24 '14 at 19:46
0

I was having the same problem, but what I did, after restoring/reseting my iPhone, deleting iCloud backups, etc, was trying to backup in a different network, and worked just fine. In the end, it was my router that was causing trouble. What I did was simply disable IPv6 internet connection. It worked, and fast!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .