3

This is my Bizarro Problem.

For a while, I have noticed that my iPhone has lost some of the music files when I sync to the Mac. First it was CDs that I had ripped, and therefore was not associated with an apple id, then it was some music I had downloaded through iTunes.

This week, with iOS8, I decided to upgrade my 5, and I got a 6. I am not using iTunes Match.

To prepare:

  1. Back up to iCloud

  2. Encrypted back up to iTunes on the Mac

    2-b - download and installed iTunes 11.4 - rebooted.

  3. Downloaded and installed iOS8 on my 5 successfully

  4. Picked up 6 today, set up by restoring from my encrypted back up on iTunes

  5. All Aps, photos, settings, passwords came over fantastically, Music did not. only 300 of 3800 songs synced.

  6. Went to Music, made sure Sync Music was clicked, and Sync Selected Songs, the blue Audio bar expanded, and I started the sync. It quickly went through the 4 steps to begin copying songs - and then abruptly stopped. this took less than a minute.

  7. Tried the above with sync all music. I have 50 gig of memory free, so I have room for the library.

  8. Switched cord I was using between phone and computer

  9. Rebuilt iTunes library - which got me to 1400 songs, rather than 300, but still not what I want.

And that is where we are at.

Ideas? thoughts?

  • I found that if you go to General > Usage > Manage Storage on the phone, and then edit and delete the songs/music that was missing; when you auto sync with iTunes, it will retrieve the missing music. I also have this problem and find it extremely annoying and wish Apple had better (more open) phone management. Deleting everything is not a great option when you have thousands of songs — it's bad on hardware and takes forever to complete, which a user/consumer should not have to afford. – vol7ron Oct 6 '14 at 0:49
3

enter image description hereMany users have reported this problem with syncing music on iOS 8. The following steps can be taken to Sync the music back onto your iPhone.

• Uncheck “sync music” in iTunes

• Delete Music (General > Usage > Manage Storage)

• Re-check “sync music”

• Sync

I did this and also had to make sure, under the Summary tab in iTunes that "Sync only checked songs & videos" AND "Manually manage music & videos" were checked. ONLY then did it sync successfully.

You must log in to answer this question.

protected by Community Sep 21 '14 at 12:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .