3

Whenever I send or receive messages on my iPhone they show up on my MacBook also. I was wondering how I could get that to stop?

It used to be that my texts wouldn't show up, and I could message through my MacBook also but now its just annoying and I'd rather not have my siblings creeping through my messages by reading them on my laptop.

  • You can temporarily disable notifications by opening the notification centre and enabling "do not disturb". – Harv Oct 22 '14 at 5:42
2

Disable it in iMessages Prefs/Accounts...

[Edit] Re-reading your question, you want to be able to send from iPhone & MacBook, but not have the MacBook show any conversations initiated from the phone?
Never tried that one, but perhaps by disabling one or more of the account number/email address options further down the same page.

I've always had conversations appear in both locations, Mac & phone, never seen it behave any differently, unless I was in some poor reception area.

Imessage Prefs/accounts pic

-2

Go to System Preferences → Accounts and unclick on the iMessaging Service.
It will say it is "inactive".

This is for OS X 10.10.

You must log in to answer this question.

protected by Community Mar 18 '15 at 9:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .