8

How do I change the colors of individual bars, in a bar chart of in Apple's Numbers 3.2.x

8

In experiencing this problem, Numbers always treated all of my bars as one series (not sure what planet that makes sense on, but whatever). You need your data treated as separate series so that you can apply a color to each series.

With the chart selected, click the Edit Data References button that appears over the chart. Then, look in the lower, right-hand corner, there will be a little tiny slightly darker gray on light gray button labeled "Plot Rows as Series" (or "Plot Columns as Series"). Change this setting and you should have separate series for each of your data points, which will allow you to change their colors.

Note that none of this is in the documentation.

As of Numbers 3.6 (possibly earlier), that's the lower left-hand corner.

screenshot

4
  1. Select the chart.
  2. Then Double click on the Bar you want to change.
  3. Go to the Fomat Panel.
  4. Use the Styles Tab to change the colour of the individual Bar

enter image description here

  • I tried this, but it does not work. Numbers only lets me select all or none of the bars. – Zach Feb 5 '15 at 5:36
  • Hmm. I just tried it again. on a standard chart in the schedule template. And it works?. So I do not know why it would not for you – markhunte Feb 5 '15 at 7:10
  • I'm guessing you either accidentally or on purpose switched the series mode for your data. If you have done that, then you can edit individual bars. See other solution below. – Zach Feb 5 '15 at 15:40
0

I found this page to be helpful - I had wanted to color the bars for control cases differently than the normal ones.

  • Please provide a little detail about how this solves the problem. Link-only posts can become useless should the link become broken in the future. Link-only post are frequently deleted for this reason. – IconDaemon May 5 '16 at 13:22
0

I hate to say this, but still have to say the previous answer is quite misleading, because it is only working if there is only 1 data point per series.

I believe here the following is the real way of doing it correctly. 1. split data by column (or transpose the table if you want) 2. define each column as different series 3. change gaps in order to optimize alignment (you may try different number, then you'll find the bars are not evenly distributed as 0% and 999% setting).

Screenshot below for setting/format.

table arrangement

Chart plotted from the table

Gap setting

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .