I checked all the answers to my question (how to add two mobile numbers to one contact in iPhone) but I didn't see a clear answer.

A lot of my contacts have more than one mobile number, and while my android phone syncs beautifully with gmail contacts (multiple mobile numbers), my iPhone 4 only allowing me one mobile number. After that when I click on add, I get a list of home,work,fax,etc. But no second mobile number.

My 5 years old Nokia phone let me add custom labels to any phone number, like I can add a number and name it "boat phone" , gmail contacts also can do it.

Any help is greatly appreciated.


2 Answers 2


A custom label will have to suffice here. I have many contacts with their cell phones listed as 'mobile', and then a custom 'Google Voice' labeled number.

An alternative to this is to make the change via Address Book.app on your computer, then sync the contacts to your phone.

Custom labels are available in all contact adding/modification screens.

First, browse to a contact, and tap the label name (to the left of a phone number, e-mail address, etc.). You will see the list of labels.

Label Screen List

Second, swipe all the way to the bottom, and tap on "Add Custom Label".

Custom Label Option

Type in a new Custom Label;

Enter Custom Label Screen

And then it will be displayed next to the number.

Custom Label on Phone Number

It will now appear in a list of custom labels on later access.

  • I don't see it anywhere in mine, and I haven't see that for a long time now.
    – cregox
    May 23, 2011 at 15:05
  • Added screenshots to explain a bit further. May 25, 2011 at 0:14
  • You see, that first screenshot is all that I see, except with no Edit button. There is no scroll down beyond other. It just bounces back.
    – cregox
    May 25, 2011 at 0:18
  • That's... very strange. And the labels match exactly? May 25, 2011 at 0:37
  • That's the strangest part - they change. I never pay much attention, but sometimes they change. Right now I've got mobile, home, work, home fax, work fax, pager, assistant, car, company man, radio... So, wtf car and radio? Anyway, it never bothered me enough to seek for a solution.
    – cregox
    May 25, 2011 at 0:40

You probably have your Google Sync turned on. Go into Settings on your iPhone, choose "Mail, Contacts, Calendars", choose the Google account your contacts are synced with, turn off "Contacts". Now you can create multiple fields with the same label.

After turning this feature off, some of your contacts may no longer appear on your phone, or they may appear with missing information. But they are still on your Google account, you can export your google contacts and re-import them into your phone instead of syncing them. Or you can sync again to bring all your contacts back.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .