17

This problem has been seen on mid-2012 MacBook Pros on Mavericks and on late-2014 Retina MacBook Pros on Yosemite.

One day while using iMessage on the Mac, all the contacts turned red and messages failed to send, immediately returning a "not delivered" error. It also reported when trying to resend the messages that the contacts were no longer associated with an iMessage account.

Things that didn't fix this behavior:

  • Deleting the com.apple.ids.madrid

  • Removing the Apple ID information from my phone, turning off iMessage on both of the devices, and placing my iPhone in airplane mode for several minutes before turning it on logging in again.

Could someone help me figure out how to solve this?

  • I had this issue when I set up iMessage on my computer after already having the same account on my iPad. It eventually started working again, but I'm not sure what I did to fix it. I'm pretty sure I did disconnect it for a few months and when I reconnected it again, it was working. – Vladimir Dec 10 '14 at 1:29
  • After a few answers, it would be good for James to edit in or explain if this issue is still happening. Lots of people are answering "Me too" so I'd like to get a thread with an accepted answer or something more definite than this thread. – bmike Jan 17 '15 at 17:52
  • come on @bmike, everyone else here plus Google all knew what james was asking. You could have helped improve the wording of his question in the time it took you to shut this down. The question helped me solve my problem, and I am grateful to have found it. – dmsnell Mar 12 '15 at 17:53
  • @dmsnell What you don't see is the spam and useless messages that this was attracting. I didn't delete it, I just closed it against new posts. What benefit is there in reopening this? I disagree that I had time to improve it. To edit it takes 5 to 10 minutes to read, understand, curate and to close it was half a second of thought once I had skimmed. Worse, this was asked before general release so perhaps it should have been closed as off-topic. Feel free to edit this to remove the beta and it will enter the queue for reopening. Cheers and thanks for asking why this was closed. – bmike Mar 12 '15 at 20:24
  • 1
    good idea @bmike. This was the first time I have ever edited a question on StackExchange so I hope I did a reasonable job. – dmsnell Mar 13 '15 at 22:05
17

One way you will get the red contacts is if the iMessages account is not enabled.

Go to iMessages's preferences. And make sure the enabled check box is ticked.

You Will also get the red contacts if you are not signed in. If that is the case you will need to sign in to see the enable check box.

enter image description here

  • This is a very basic solution. It's not the one I need, I'm past all the simple things. I've tried the easy stuff, there's something way wrong with it. Thanks though. – James Sep 19 '14 at 23:38
  • @James , yes it is. But if you put more information in your question of what you have tried on your Macbook then you maybe you will not answers that include those.. Please edit your question with such details. – markhunte Sep 20 '14 at 6:54
  • I've added details such as deleting files that were suggested to delete, I know how to be logged into something. – James Sep 20 '14 at 19:47
  • 1
    @Markhunte - Thanks. I'm new to the apple world and your solution worked perfectly for me. I would never have guessed it signed me out. – user99916 Nov 9 '14 at 17:28
10

What I did that seems to have worked:

iOS Device > Settings > Messages > Text Message Forwarding

Turned off the selection for my iMac & then turned it back on. Entered the code that showed up on my computer & all worked again.

  • 1
    Just to clarify, one needs to go to Settings > Messages on the iPhone, not the Mac. This solution worked for me. – mjswensen Mar 1 '15 at 4:39
  • Although I was never presented with a code on my Mac, apparently trying to toggle this setting was enough to make things start working again for me. – dmsnell Mar 12 '15 at 17:48
1

Go to System Preferences and iCloud, then click on Account Details to verify your connectivity to iCloud.

If you've got:

Account Details could not be opened because of an error connecting to iCloud.

then try to Sign Out and Sign In again. One of the reason could be that Apple recently tries to force and upgrade security for users to use Two-factor authentication.

To check the iCloud errors, run the following command in Terminal:

log stream | grep -i iCloud | grep -C5 -i error

If the problem is somewhere else, try running the following log command in Terminal to debug the problem:

log stream --predicate 'processImagePath contains "Messages"'

or:

log stream | grep -C5 -w Messages

or check in Console app, then re-send the message and check for any hints or errors.

0

try to change your apple id to a new one just for imessage. i have the same problem as yours, icloud is all working thru mac and idevices. facetime also works with old apple id. only messages in mac ( seems cannot connect to the server or something is wrong with the appleid for messages server) and in my iphone, everytime i try to re-loggin again my old appleid, it sends messages and receive messages from anyone, i can send imessage to myself, only when i try to send imessage to my appleid(email add) it says delivered but i cannot get it back from my phone. same also with my mac. if my old appleid was logged in, all my contacts as red, but when i try to send a message to myself, i can receive it, but i cannot send to anyone. so what i did was use a new apple id specific for imessage only. both mac and iphone are working... messages are sync. :-)

  • I hoped this would work but nothing ended up happening :/ – James Sep 19 '14 at 15:32
0

I hope my encounter with Apple support helps.

I had a couple things happen. When I registered my iPhone to send the code to my laptop, my Mac never received the code. I could send messages from my Mac to other iPhone users but not to Android users. In the end, the problem was all on the iPhone side of the equation.

On your iPhone, under Settings → Messages, you should see a box called Text Message Forwarding. Enable this setting. I had it disabled and tried to send the code, but my Mac never got the code. (Also enable Send as SMS, MMS Messaging and Group Messaging if you want these features). We also signed out and back into iCloud on my mac and that didn't help.

I hooked my iPhone up to my Mac to back it up and left it plugged in the entire time we found the solution. (No idea if this had any impact.)

On the iPhone, we disabled restrictions found under Settings → General → Restrictions. Enable Handoff and Suggested Apps under Settings → General.

Here is the odd part, the box called Text Message Forwarding had disappeared. Text support wanted to wipe my iPhone. Instead we reset the network settings under Settings → General → Reset. Select Reset Network Settings. Once I did this, the Text Message Forwarding box re-appeared. Once activated, a code appeared on my Mac. At this moment, I don't know if Bluetooth was active or not but Wi-Fi was Off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .