1

The only source for my iPhone contacts is my GMail account.

I've cleaned up "My contacts" in GMail, but those contacts didn't get removed from my iPhone/iOS 7.0.

I tried to set the GMail contact sync mode to "Manual" and ran "Contacts" app, and tried to set it to "Hourly" - they just won't go.

Is it possible to achieve?

1

You might have to force iOS to refresh your contacts. Goto your iPhone's Settings and select Mail, Contacts, Calendars. Select Gmail and uncheck Contacts. Now, goto your Contacts app and it should be empty. Go back to the previous settings screen and recheck Contacts. After that, open up your Contacts app to verify the updates.

|improve this answer|||||
  • I'd add that if the Contacts app is not empty after disconnecting from GMail: Those contacts exist only on your iPhone. You will need to manually copy them over to GMail - and also change Settings -> Mail, Contacts, Calendars -> under the Contacts section make sure the default is set to GMail (not "On my iPhone). – RedYeti Sep 16 '15 at 11:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .