3

So i'm getting really frustrated with the new and the best feature of iOS 8 - Handoff. I've tried many different ways to make it work, but nothing helped:

  • Tried various methods of restarting both devices (with Handoff checked, without).
  • Tried turning off/on bluetooth, AirDrop, WiFi.
  • Changed AirDrop to Contacts Only / Everyone.
  • Changed different WiFi networks (we're using AirPort Extreme in our office, so that should not be a problem).
  • Tried tinkering with iCloud options (turning on/off various services).
  • Tried to turn passcode on/off.
  • Tried to turn on/off shared apps settings (my apps, app store).

I have an iPhone 5S and iPad Mini Retina, so incompatibility for hardware reasons is out of question here.

And another weird thing is that my colleague has an iPhone 5 and iPad Mini Retina, and Handoff works for him perfectly. We both don't have Yosemite on our Mac Airs yet, so that is off the question here too.

What could be wrong? How can i possibly find atleast where to start with this problem? The answers on the interwebs are scarce, and i would need at least a way to find some log, or something like that to begin with (I Have IT background, so im hopefull at least to find a thread to hang on).

This is the best feature for me in iOS 8, the one I was waiting for, and now that this is happening... I'm out of words about how Apple works... And I think there are many people with same problem, so maybe some of you had found a way to fix this?

  • So i've noticed one interesting thing. My iPhone does not appear as registered with my Apple Id, although it was setup with iCloud (screenshot - dropbox.com/s/hv6dm7fbe9jns0w/…)... What the? – fosron Sep 18 '14 at 10:29
3

Ok, so the problem here was that somehow my iPhone was connected to iCloud... But it wasn't at the same time... This is really weird, and Apple should at least notify on this somehow, because my iPhone was connected to iCloud and synced. Wow.


Worked the same for me, though also required e) after a) to d):

a) going to the apple discussions (as mentioned) to 'register' my device(s) with my apple id. (weird)

b) turning iMessages off and on (on both devices)

c) turning my icloud off and on (on both devices) (scary dialog boxes, push on)

d) turning by bluetooth off and on (on both devices)

and finally, after none of that worked,

e) turning both devices off and on.

Presto, it finally worked. The feature only seems to work if the email or message or calendar (whatever you want to hand-off) is actually open on the screen on one of the devices. Unlock other device and the email or messages or whatever icon appears bottom left. Swipe it up and roll.

I have had a few of these issues with icloud and apple id's. Seems like you really have to reset all icloud and messages services to get hand-off working properly.

  • One way to check if iCloud is set up correctly - go to Apple Support Community, try to create a new post (discussions.apple.com/discussion/…) and look down where you can select your product. If it's not there - reconnect it to iCloud (Settings->iCloud->Sign Out), and even try to register it with the Apple Support Community (supportprofile.apple.com/regProd) because it helped me. – fosron Sep 18 '14 at 10:57
  • Thanks to @fosron for the suggestion, this fixed it for me. Key is to log on to "Manage my Apple ID" and ensure that your devices are registered with iCloud. – Nick Farina May 4 '15 at 19:54

You must log in to answer this question.

protected by Community Sep 18 '14 at 18:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .