7

I am using Macbook running Mavericks OS.

Recently I hace synced my Google calendar with Apple calendar in my Mac, but then I regularly get this error message:

The server responded with an error.

The request for “International Observe the Moon Night” in “kixxxxxxx@gmail.com” in account “Google” failed.

The server responded with “400” to operation CalDAVWriteEntityQueueableOperation.

enter image description here

I believe many others have got this error message.

Can someone tell me how to resolve this?

3
  1. Close the Calendar Program
  2. Remove the two caches (Or squirrel them away someplace, just in case.)

~/Library/Calendars/Calendar Cache

~/Library/Caches/com.apple.iCal

  1. Open Calendar and wait for it to synchronize.

This takes care of most problems that are do to some sort of caching issue.

[For Advanced users] If that doesn't work, you can disconnect from the networked accounts, export backups of you local calendars (make sure you have good solid backups of everything!), then move ~/Library/Calendars out of the way. Start Calendar, restore your local calendars, and re-connect your network calendars. Once everything synchronizes, your calendars should be clean.

If you continue to have issues, you may have to be patient and wait for Google to fix an issue with their servers.

  • 1
    In Yosemite, re/moving this ~/Library/Calendars/Calendar Cache will delete the calendar account. – f01 Jan 5 '15 at 6:54
  • I had multiple directories in Yosemite like Calendar Cache-abc as well as one without the random dash + three-letter suffix but removing them all didn't solve my problem. Restarting the app added them all back. – tripleee Nov 25 '16 at 9:55
  • Same here, removing any of those files completely destroys my calendars. This one: apple.stackexchange.com/questions/145567/… helped me for new events. – schmunk Dec 4 '17 at 16:29
1

I got this same error when copying and pasting my husband's flight departure iCal item to the date that he was returning. I had just planned to change the word "departure" to "arrival" in the event to save time rewriting all the info. Boy was I bummed when this error showed up.

I looked at many many answers to this issue and was chagrined to see things about moving files, deleting files, backing up my calendar, reinstalling Yosemite (FYI: I'm on 10.10.3 on a MacBook Air).

Here are the key words associated with my error that will hopefully help people search and find this later: Error "400" to operation CalDAVWriteEntityQueueableOperation

Here's what I did that finally worked. Repeated the process because I accidentally triggered the server error again when I clicked on the offending iCal item that started the whole mess (it was there, so I thought I'd edit it).

I am going to speak from the viewpoint of a non-technical person (that's me, kind of. I'm a technical marketing copywriter):

  1. With iCal open, and the popup message with the server error and all the text below that's associated with the "offending" iCal item, do a select all (Command+A). This lets you select even the text below the bottom of your screen... important text to select).
  2. Copy and paste the entire message into a word doc.
  3. At the very bottom of the message, you'll see that it has a problem with one of your iCal calendars (e.g., I have these: work, home, kid calendar, school). For me, the problem was noted as being in my "work" calendar. Makes sense, as this is my default calendar, and I have to assign a different calendar if I want to add an iCal event to my home or kid calendar... you get the gist).
  4. Force quit iCal to close it (if you don't know how to force quit, you do it by pressing alt+command+esc, selecting iCal from the list of open apps that appears in the popup, and clicking the Force Quit button).
  5. Open System Preferences > Internet Accounts > iCloud.
  6. Select iCloud in the left side list. Things associated with iCloud show up to the right.
  7. In the list to the right, uncheck the Calendars checkbox. (I also unchecked reminders and contacts just in case).
  8. Reopen iCal. You'll see that all your iCloud calendars are gone. You'll still see calendars under "Other", which include for me US holidays and Birthdays.
  9. If it's not still open open, repeat step 5 to open the iCloud window in which you unchecked "Calendar." Sorry I don't know the official name for that window. BEFORE YOU DO ANYTHING ELSE, READ STEPS 10 THROUGH 12 BECAUSE YOU HAVE AROUND 5 SECONDS TO COMPLETE THOSE STEPS BEFORE THE ERROR MESSAGE POPS UP AGAIN AND YOU HAVE TO REPEAT STEPS 4-9.
  10. Before the server error message pops up again, you need to do these things:
  11. Click the Calendar checkbox to turn it back on.
  12. Quickly uncheck the box next to the calendar that has the offending item. PHEW. NOW YOU CAN RELAX.
  13. Click once on the name for that same calendar (the one you turned off). Then click it again to be able to rename it. Rename it with a different name. I renamed mine "Work2".
  14. Click the checkbox next to the renamed calendar. It turns on all the items associated with that calendar and the error message does not pop up any more. Unless, of course, you select it and spend time trying to do something with it. ONCE AGAIN, DO THIS QUICKLY... BEFORE ERROR MESSAGE POPS UP.
  15. Quickly select the offending iCal item that you were creating when your issues started and hit delete.

Problem solved for me! I hope it works for you!

BTW, no loss of data, calendar items, etc occurs by just switching off your iCloud Calendars. I was unable to export or backup my calendars (that option was grayed out for me), so this resolution seemed like my only option other than manually writing down all my calendar items.

0

See three possible techniques below.

Technique 1:

Taking hints from above, in Yosemite after re/moving ~/Library/Calendars/Calendar Cache I have to re-add a CalDav Account using hints from their support page https://support.google.com/calendar/answer/99358?hl=en to fix Calendar.app's Accounts listing.

For some reason all the accounts disappear and the Add button prevents me from adding a Google account. After typing the password and pressing "Set up" it empties all the fields and goes back to the email field. Adding a CalDav account reinstated all the calendar accounts (set in Systems Preferences > Internet Accounts).

These are the settings I used.

Account Type: Manual
Username: REPLACE@gmail.com (or username@google_apps_domain.something)
Password: App-specific password if you are using 2-step Authentication
Server: gmail.com

Technique 2:

I also tried wrapping my connection with VPN. It also appears the cause is Google blocking my ISP (NAT on 3G/LTE).

Technique 3:

I also noticed sometimes that when I get The server responded with “400” to operation CalDAVWriteEntityQueueableOperation. my accounts Google accounts under System Preferences > Internet Accounts will need a re-login and re-key of OTP. This might be Google authentication service issue.

You must log in to answer this question.

protected by Community Nov 1 '15 at 20:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .