6

I use my gmail as my primary email address and use the gmail app on my iphone.

However, whenever I want to send a picture quickly from my camera roll it uses the default mail app and then proceeds to download all the emails it perceives as unread. All this mail is already in my gmail app,filed to read as I like.

Is there any way to set the ios mail to send only?

Thanks

6

You can setup iOS to send only, you just have to fool it :)

Here is how I did it on iOS 7...

  • If you have an existing GMail account setup in iPhone Mail, delete it.
  • Go to Settings > Mail, Contacts... > Add Account
  • From the list of choices, select Other
  • Select Add Mail Account
  • Fill in your details for your mail account, press Next
  • Choose POP instead of IMAP
  • For Incoming Mail Server I used dummy info like
    • Server: blah.gmail.com
    • User Name: blah
  • For Outgoing Mail Server I used the proper settings
    • Host Name: smtp.gmail.com
    • User Name:
    • Password:
  • Press Save
    • If it asks to save without SSL answer with NO
  • Press Save again!
    • It will warn you that it may not work. Confirm save.
  • Go to Settings > Mail,Contacts,... > 'your account' > SMTP > Primary Server
  • Verify SSL is on
  • Change Server Port to 587
  • Press Done and exit to Accounts.

That is it! You can now send emails and if you open the mail app it will complain because of the dummy Incoming Server.

Also check that you have the Settings > Mail,Contacts....> Fetch New Data settings to off/manual.

Hope that helped.

  • Smart tip. Although I find iOS Mail alerts (when it can't connect to a mail server) simply maddening. I wish you could turn them off. – magma Jul 21 '15 at 21:41
  • For it to work for me, I had to go to my gmail settings and then set it to allow insecure clients: "Google will continue to block sign-in attempts from the app you're using because it has known security problems or is out of date. You can continue to use this app by allowing access to less secure apps, but this may leave your account vulnerable." at google.com/settings/security/lesssecureapps – David d C e Freitas Jan 4 '17 at 16:07
1

The good answer by Vic above almost did it for me, but it made me realize there is this method too, which disables incoming mail by using the disallowed non-ssl:

  1. Add your gmail account as per normal if needed.
  2. Go to Mail in Settings, to your Account, then Advanced and finally switch off Use SSL under INCOMING SETTINGS.

This cancels the ability for normal mail fetching to happen. You will have to press Done/Save again after the error pops up about imap not working etc

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .