3

I would like to set up Eclipse to run for all users of a Mac running OS X 10.9.4 (Mavericks). I logged in to the administrator account (User) and did the following:

  1. I installed the latest version of the JDK (jdk-7u67-macosx-x64.dmg).
  2. I downloaded the tarball of the latest version of Eclipse standard Luna.
  3. I double-clicked on the tarball (eclipse-standard-luna-R-macosx-cocoa-x86_64.tar.gz) to uncompress/unzip it.
  4. I dragged the created eclipse folder into Macintosh HD/Applications.
  5. I double-clicked on the Eclipse Application in the eclipse folder and launched Eclipse.

The problem occurs when I log out of the administrator account and in to an ordinary user account. When I double-click on the Eclipse Application, I get this error:

You can't open the application "Eclipse" because it is not supported on this type of Mac.

I don't think this is the real reason. I am able to run Eclipse as an ordinary user if, as that user, I uncompress that same tarball and launch its Eclipse application.

Back to the version I installed as User, if I try running Applications/eclipse from the command line as an ordinary user, I get this error:

-bash: ./eclipse: Permission denied

Digging through, looking for a permissions problem, I found:

-rwxr-x---@ 1 user  staff  34608 Jun 12 01:08 /Applications/eclipse/Eclipse.app/Contents/MacOS/eclipse

After chmod'ing this file to 755, I can get Eclipse to run for ordinary users if they double-click on the link /Applications/eclipse/eclipse in the Finder. This seems like a hack, though, and lacks robustness. Specifically, I'd like to get the Eclipse Application working so it can appear in the dock. If I launch via the eclipse link /Applications/eclipse/eclipse and then right-click on the Eclipse icon in the dock and save it, I cannot launch with it later, or I get the same error as above:

You can't open the application "Eclipse" because it is not supported on this type of Mac.

What is the right fix?

0

I fixed the problem with:

chgrp -R everyone /Applications/eclipse

A way to preempt the problem, for anyone doing a new installation, is to do the following before unzipping the tarball:

newgrp everyone
  • I tried this without success. Any other ideas? – Fyrefly Apr 17 '15 at 17:53
  • @Fyrefly In what way did it not succeed? What error did you get? You may need to be superuser to run those commands. – Ellen Spertus Apr 17 '15 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .