1

I got a 2011 MacBook Pro and had a Samsung 840 Pro installed running Mountain Lion, then Mavericks for about a year without any problems. Without any apparent reason the MBP just wouldn't boot from the SSD anymore, reinserting the old HDD worked instantly. After playing around a bit I made the following observations about the MBP:

  1. won't boot from the SSD even after cloning the HDD or making a clean reinstall
  2. not even able to get to the boot menu when the SSD is installed
  3. can boot from the SSD when it is connected via USB and the HDD is used to get to the boot menu
  4. cannot boot from any other SSD (tried one from another MBP and also a completely new one)

Any ideas?

  • Reset your SMC and EFI. And check your SSD connection cable, it might be bad. – Ruskes Sep 16 '14 at 21:53
  • I have the same problem, trying to boot from SSD always results in a kernel panic. Resetting SMC didn't work, and I don't have an EFI password set. Are there any other options to fix it (possibly a TRIM issue? I tried enabling and disabling trimforce, but I had no luck). Thank you! – Thomas Dec 30 '16 at 23:13
1

I don't know how it worked without issues for over a year... but the culprit is probably the drive cable. To put a long story short, the interface is SATA III on the motherboard, it's SATA III on the SSD, so they will talk SATA III.

But if your MBP shipped with a SATA II HDD, it most likely came with an interconnect cable only rated for SATA II.

I wouldn't have thought this would be that big of an issue (I sort of thought the difference was like the difference between a CAT 5 and CAT 5e UTP) but apparently with the models of SSD's on the market right now and their throughput, it causes an issue.

I couldn't tell you how to determine if the cable's the "updated" SATA III version or not when shopping for parts, but I do know that this one is.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .