4

I selected the encrypt disk option from the Finder initially, but after several days without progress (I checked diskutil cs list and it didn't show that it was either encrypted or converting) I ejected the drive, plugged it back in, and tried again from the command line.

First of all, encryption status showed Pending and didn't change, so I tried encrypting it again to force it to start, but that didn't work and gave the error shown below.

I then tried decrypting and reencrypting. But I still get the following two errors (output cleaned up):

> diskutil cs decryptVolume vol
Error beginning CoreStorage Logical Volume decryption: The target Core Storage volume is not encrypted (-69755)

> diskutil cs encryptVolume vol
Error: -69696: The target Core Storage volume is already encrypted

Apparently this was Schrödinger's Hard Drive.

So then, I ejected it, unplugged it after ejecting, and plugged it back in. But now it doesn't mount. I tried unlocking from the command line, and I get this:

> diskutil cs unlockVolume AAAAAAAA-AAAA-AAAA-AAAA-AAAAAAAAAAAA
Error: -69774: Couldn't bring the new Core Storage Logical Volume online

From Disk Utility, trying to mount or unlock does nothing. For completeness, here's the complete output of diskutil cs list:

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group XXXXXXXX-XXXX-XXXX-81XXXX92-XXXXXXXXXXXX
    =========================================================
    Name:         vol
    Status:       Online
    Size:         3000144142336 B (3.0 TB)
    Free Space:   16777216 B (16.8 MB)
    |
    +-< Physical Volume YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk3s2
    |   Status:   Online
    |   Size:     3000144142336 B (3.0 TB)
    |
    +-> Logical Volume Family ZZZZZZZZ-ZZZZ-ZZZZ-ZZZZ-ZZZZZZZZZZZZ
        ----------------------------------------------------------
        Encryption Status:       Locked
        Encryption Type:         None
        Conversion Status:       Converting
        Conversion Direction:    -none-
        Has Encrypted Extents:   Yes
        Fully Secure:            No
        Passphrase Required:     No
        |
        +-> Logical Volume AAAAAAAA-AAAA-AAAA-AAAA-AAAAAAAAAAAA
            ---------------------------------------------------
            Disk:                  -none-
            Status:                Locked
            Size (Total):          2999808593920 B (3.0 TB)
            Conversion Progress:   -none-

I also tried diskutil repairVolume disk3s2 and it completed, but didn't help. Also, diskutil cs revert ... gives the following error:

Error: -69854: A disk with a mount point is required

What should I do here? I do have an offsite backup, but if I can get it working it'll save me a substantial amount of downtime.

1

If this happens to you... your disk is probably hosed. Find your backups.

(I'm still interested if someone does have a solution, but given the lack of answers I don't think it's likely.)

  • Your answer to your own question is not really an answer that is useful at all that addresses your question. – jamescampbell Oct 4 '17 at 15:41
1

I got this fixed using Tech Tools Pro 9. It was an issue with btrees. Fixed and mounted properly again from then on. So your disk is not 'probably hosed', it is fixable using the proper software to identify and repair the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .