11

I would like to toggle the Do Not Disturb in the notification center with a keyboard shortcut.

I am using BetterTouchTool for some extra keyboard shortcuts but it does not support enabling/disabling the notifications in the default options.

It has an option for executing a terminal command so I'm asking here how to enable/disable Do Not Disturb from the terminal?

I found Schedule ‘Do Not Disturb’ In OS X Mountain Lion With Automator and I tried to run the commands but it didn't seem to work.

  • Since you're really asking about how to get it done from a keyboard, as opposed to from the shell, you should probably change the title of the question. Or if I'm wrong, please correct me! – webmarc Sep 16 '14 at 15:13
  • Actually, never mind... I didn't realize that "betterTouchTool" requires the terminal for what you want. – webmarc Sep 16 '14 at 15:21
  • I primarily asked how to do it from the shell. Doing it from the system preferences solves my case, but it's more fun to know how to do it from shell. – Razvan Sep 16 '14 at 15:23
  • Gotcha, I updated my answer with the shell info. – webmarc Sep 16 '14 at 15:24
10

You can just setup a global keyboard shortcut for it in System Preferences -> Keyboard -> Shortcuts -> Mission Control

Or if you definitely want it from the command line, an applescript to do this (assuming you setup the keyboard shortcut to use cmdshiftoptctrlD.

Note that you still MUST setup a keyboard command in System Preferences for this to work.

Put the below script into a file, say, ~/dnd.applescript

ignoring application responses
    tell application "System Events" to keystroke "D" using {command down, shift down, option down, control down}
end ignoring

Now you can run osascript ~/dnd.applescript from the command line to toggle your DND setting.

Screencap: Keyboard shortcut modification in System Preferences

  • 1
    Perfect! Thanks. Wish there were a better way though. – Will B Dec 10 '14 at 15:30
  • Better in what way? – webmarc Dec 10 '14 at 15:48
  • 1
    Not having to bind an obscure keyboard shortcut and toggle that with osascript. – Will B Dec 10 '14 at 15:49
  • I guess I'm asking if you mean better as in "more effective" or better as in "prettier under the covers." Is it a practical or aesthetic wish? – webmarc Dec 10 '14 at 15:52
  • Just curious, I don't have any additional suggestions either way. – webmarc Dec 10 '14 at 15:53
15

As of OS X 10.10.3, this AppleScript will toggle "Do Not Disturb." No keyboard shortcut required:

tell application "System Events" to tell process "SystemUIServer"
  key down option
  click menu bar item 1 of menu bar 2
  key up option
end tell

You can save it as an AppleScript and run it from the terminal with osascript DoNotDisturb.applescript, or you can include it in a Bash script by wrapping it in in a heredoc like so:

#!/bin/bash
osascript <<EOD
  tell application "System Events" to tell process "SystemUIServer"
    key down option
    click menu bar item 1 of menu bar 2
    key up option
  end tell
EOD
  • 6
    This means that you can also toggle DoNotDisturb by clicking the rightmost tiles in the menu bar while holding the Option key. – Razvan May 12 '15 at 17:18
  • This no longer works on Mojave. Applescript seems to click the menu bar item as if option was not down, even though it is – Dylanthepiguy Mar 14 at 20:21
7

Building on answers from James and Zsolt, I've created a couple of scripts to turn on or off (not toggle) DND state. They also don't require any key bindings or machine GUID to work.

IMPORTANT: Please note that running these scripts for the first time may require accessibility permission for the app which runs the scripts. If you do not grant the permission in the request the alt/option button will remain pressed for the system and you will need to log out and back in to "unpress" it. This is also true for previous answers with AppleScript. If the script is edited, the permissions will need to be revoked and re-granted. Permissions are granted using:

System Preferences > Security & Privacy > Accessibility > Add your app

For macOS Sierra and High Sierra it's menu bar 1:

Turn Do Not Disturb ON (disable notifications):

if [[ $(plutil -convert xml1 -o - ~/Library/Preferences/ByHost/com.apple.notificationcenterui.*.plist | grep false) ]]; then
    osascript <<EOD
      tell application "System Events" to tell process "SystemUIServer"
        key down option
        click menu bar item 1 of menu bar 1
        key up option
      end tell
EOD
fi

Turn Do Not Disturb OFF (enable notifications):

if ! [[ $(plutil -convert xml1 -o - ~/Library/Preferences/ByHost/com.apple.notificationcenterui.*.plist | grep false) ]]; then
    osascript <<EOD
      tell application "System Events" to tell process "SystemUIServer"
        key down option
        click menu bar item 1 of menu bar 1
        key up option
      end tell
EOD
fi

For earlier versions of macOS it's menu bar 2:

Turn Do Not Disturb ON (disable notifications):

if [[ $(plutil -convert xml1 -o - ~/Library/Preferences/ByHost/com.apple.notificationcenterui.*.plist | grep false) ]]; then
    osascript <<EOD
      tell application "System Events" to tell process "SystemUIServer"
        key down option
        click menu bar item 1 of menu bar 2
        key up option
      end tell
EOD
fi

Turn Do Not Disturb OFF (enable notifications):

if ! [[ $(plutil -convert xml1 -o - ~/Library/Preferences/ByHost/com.apple.notificationcenterui.*.plist | grep false) ]]; then
    osascript <<EOD
      tell application "System Events" to tell process "SystemUIServer"
        key down option
        click menu bar item 1 of menu bar 2
        key up option
      end tell
EOD
fi
  • This no longer works on Mojave. Applescript seems to click the menu bar item as if option was not down, even though it is – Dylanthepiguy Mar 14 at 20:22
7

You can simplify the answer that razvanz provided by using the -currentHost argument to the defaults command.

Enable Do Not Disturb:

defaults -currentHost write ~/Library/Preferences/ByHost/com.apple.notificationcenterui doNotDisturb -boolean true
defaults -currentHost write ~/Library/Preferences/ByHost/com.apple.notificationcenterui doNotDisturbDate -date "`date -u +\"%Y-%m-%d %H:%M:%S +0000\"`"
killall NotificationCenter

(via https://heyfocus.com/blog/enabling-do-not-disturb-mode/)

Disable Do Not Disturb:

defaults -currentHost write ~/Library/Preferences/ByHost/com.apple.notificationcenterui doNotDisturb -boolean false
killall NotificationCenter

Now you could easily wrap this up as a script to enable or disable "Do Not Disturb" as a script that would work on anybody's machine regardless of system preferences. Here is an example of how to do that:

#!/bin/bash

set -eou pipefail

# From https://heyfocus.com/enabling-do-not-disturb-mode and
# https://apple.stackexchange.com/questions/145487

if [[ $(defaults -currentHost read ~/Library/Preferences/ByHost/com.apple.notificationcenterui doNotDisturb) -eq 0 ]]; then
  defaults -currentHost write ~/Library/Preferences/ByHost/com.apple.notificationcenterui doNotDisturb -boolean true
  defaults -currentHost write ~/Library/Preferences/ByHost/com.apple.notificationcenterui doNotDisturbDate -date "`date -u +\"%Y-%m-%d %H:%M:%S +000\"`"
  killall NotificationCenter
  echo "Do Not Disturb is enabled. Run $0 to turn it off (OS X will turn it off automatically tomorrow)."
else
  defaults -currentHost write ~/Library/Preferences/ByHost/com.apple.notificationcenterui doNotDisturb -boolean false
  killall NotificationCenter
  echo "Do Not Disturb is disabled. Run $0 to turn it on again."
fi

Source: https://gist.github.com/ryangreenberg/5267f68a8e7b07ea66370b4eb5580ab9

  • 1
    Minor visual bug! [Noted for folks who look @ color]: I tried this and it sorta works. I snoozed some notifications for 5 mins, and then turned on Do Not Disturb for Notifications, and then ran the commands under "Disable Do Not Disturb". On the one hand, the icon remained greyed out, but on the other, it did appear to work otherwise - notifications popped up in a few minutes. Second test: I turned on Do Not Disturb for Notifications (w/o snoozing anything), & ran the commands under "Disable Do Not Disturb". The icon remained greyed out, but notifications popped right up. – Matthew Elvey Feb 23 '18 at 16:19
  • 1
    @MatthewElvey That might be a change from Sierra to High Sierra. We probably need to find a new way to reload the menubar icon. – Ryan Mar 5 '18 at 23:57
  • 1
    +1 for non-Applescript command! – Matt Sep 19 '18 at 17:29
  • Dnd doesnt appear to be changed on high sierra/mojave with this solution – Dylanthepiguy Mar 9 at 23:09
0

Building on James's answer, I'd also liek to point out that you can also determine if it is turned on or off. So the following turns it off, and does nothing if already off:

if [[ $(plutil -convert xml1 -o - ~/Library/Preferences/ByHost/com.apple.notificationcenterui.000-000-000-000.plist | grep false) ]]; then
    osascript <<EOD
      tell application "System Events" to tell process "SystemUIServer"
        key down option
        click menu bar item 1 of menu bar 2
        key up option
      end tell
EOD
fi

You must substitute your own machine GUID into the filename (there is only one file there, so it's easy to figure out)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .