7

Very often by the time I get tothe phone it's lock screen is already on and black so when i wake it up the alarm goes to snooze and i have not found any way to disable the alarm for today unless I go to the alarm settings and switch it off and on again.

5 Answers 5

14

Instead of swiping the snooze to the right like you would if unlocking, swipe to the left, then push the x. Done

Before swiping, the screen will look like this:

before swiping

After swiping left on the "Snoozing" message, you should see:

after swiping

Clicking on the small cross should then cancel the alarm.

6
  • @bornfromanegg not everyone comes back or even understands what the Accept mark does. Keep on voting and asking and answering. That's the best way to grow the site :)
    – bmike
    Oct 21, 2015 at 15:12
  • @bornfromanegg because on my 5c and ios931 it doesn't want to swipe to the right; swiping the alarm itself to the left unlocks the phone then SLEEPS the alarm again. That might be why it's not more accepted.
    – frumbert
    Apr 3, 2016 at 21:12
  • @frumbert I have iOS931 and it works fine. "Swiping to the left" means placing your finger on the screen and moving it to the left. If you do this on the "Snoozing: x:xx remaining" message you get on the lock screen after you have snoozed, then a delete button (an 'x' in a circle) appears. Remember, this question was about how to cancel the alarm after it has been snoozed. Apr 3, 2016 at 21:28
  • @bornfromanegg yes, after the alarm has been snoozed, swiping to the left as you say does NOT produce the delete button on my iPhone5C iOS9.3.1
    – frumbert
    Apr 4, 2016 at 1:00
  • 1
    I've added some screenshots to the answer. (They will need to be reviewed before they appear, but I hope they will help). Apr 6, 2016 at 19:37
2

As you already know, if you unlock your phone while the alarm is going off, the alarm is acknowledged and won't sound again until the next day.

If the alarm is snoozing, it seems that the only way to prevent it from going off again is to manually turn it off (and on) again. The only help I can offer is recommending that you unlock the phone by sliding the clock icon where it says "Snoozing" on the lock screen, as that will at least take you directly to the alarms menu.

I imagine that they have this obstinate functionality because people might use alarms for other purposes than waking up, and they might be using their phones for other things and perhaps don't see the alarm.

3
  • That is not what happens for me, otherwise I wouldnt be unhappy about it. Maybe because i disabled the unlock password and fingerprint scan?
    – Blub
    Sep 23, 2014 at 5:30
  • Hmm... I'll have to try to make it happen for me. I feel like it has happened under some circumstances like you say. I'll let you know what I find.
    – krs013
    Sep 23, 2014 at 6:24
  • Yeah, it doesn't turn off unless you get it while the alarm is going off, huh.
    – krs013
    Sep 23, 2014 at 6:43
2

Everybody is missing the point. He said that, by the time he got to the phone, it was already black. Swiping doesn't work. Hitting buttons doesn't work. I know. It happens to me. The one thing you can do is to tell Siri to turn off all your alarms. That works 9 out of 10 times for me, but sometimes it doesn't. I think it would be nice if the phone didn't go black so fast. Then you could pick it up and swipe to the right.

-2

Just activate it with the home button then you can slide then lock the phone

-3

Try restarting the phone. It worked for me. All thought it's a year later lol

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .