0

Okay I'm just going to list out what has happened over the past 24 hours:

  • Lost a bunch of files.
  • Tried to restore from backup. After waiting for about an hour, it just randomly stopped at around 40/50% and went back to OS X Utilities.
  • Tried again, did the same thing.
  • Reluctantly tried again, and obviously it did the same thing.
  • I then tried to reinstall OS X Mavericks. After waiting about 6 hours (British countryside internet) to download, then another half an hour to install, it rebooted and then got stuck at grey Apple screen with loading icon. Left it overnight, woke up 7 hours later and it's still on the same screen.
  • Since then I have tried resetting PRAM, SMC, safe boot, unplugging all peripherals etc. a lot of things I have seen online, however none of them have worked.

Obviously I've backed up with Time Machine to an external hard drive, so wiping Macintosh HD shouldn't be a problem as a last resort.

Here are my Mac's specs:

  • Late 2012 27" iMac
  • Intel Core i7 3.4GHz
  • 8GB RAM
  • 1TB Fusion Drive
  • NVIDIA GeForce GTX 680MX
  • Whatever the latest version of Mavericks is. (10.9.4 maybe?)

Thanks in advance for any help!

1

Use the recovery mode of OSX to run Disk Utility so that you can check whether your HDD is faulty. See:

https://www.apple.com/osx/recovery/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .