0

I had Internet Sharing working correctly on my iMac with OS X 10.9.4. I was sharing my connection from ethernet to computers using Wi-Fi.

After I rebooted, my iPhone can connect to the Wi-Fi connection from the iMac OK, however has no internet access. I can access the iMac's local server pages, but not google.com etc.

I have rebooted numerous times. What can I do to fix this issue?

I am behind a cooperate proxy which settings are set correctly.

  • I am assuming you have ticked the wifi box under internet sharing in system preferences. What, if anything, have you set under internet sharing wifi options? – Jerry W. Sep 25 '14 at 13:37
  • Just the network name and security details? @jer-el – burrows111 Sep 29 '14 at 14:29
1
+25

The best option here is to speak to your employer's technical support people.

If their policies permit the sharing of the wired corporate network to wireless devices they should assist you in setting up the connection or at least point you in the right direction.

If they do not, then it is probably best not to breach their policies.

  • I can't see them being too happy about it, however that doesn't constructively answer the question to the problem. It was once working, then without changing anything it stopped! – burrows111 Sep 29 '14 at 14:30
1

Have you excluded a DNS issue. Can you connect to an external site using the IP address, instead of the resolved name. Can you try and open http://173.194.45.48 instead of http://www.google.com? If this works, the DNS on your iPhone is somehow screwed.

Assuming you can connect outside your mac using an IP check the DNS settings in the networking panel of both the mac sharing and the iPhone receiving the shared connection

  • If you determine that your DNS settings are acting strangely, I suggest changing them to 8.8.8.8 and 8.8.4.4. These are Google Public DNS, and I've found them to be a lifesaver at times. – Thomas Jones Sep 29 '14 at 11:52
  • 1
    Thanks @ThomasJones - that didn't fix the issue. However as I can browse the iMac WIKI pages etc I'm assuming a DNS issue, but I'm struggling to locate the problem! – burrows111 Sep 30 '14 at 10:12
  • Normally when you connect you will be given the DNS server by the dhcp server. The dhcp server will be your internet sharing iMac. But you can force to use a different one for your iPhone. Go to the Settings app, choose the wifi connection of your iMac. There you will see the information of your connection. Tap on the DNS text field and change the DNS to 8.8.8.8 as was suggested earlier. See if you now can connect to external sites. (You may use connectivity to external machines, as you are now using an external DNS.) – Andrew Maier Oct 1 '14 at 13:51
  • This turned out to be the problem for me. – Mark Suman Jun 4 '15 at 15:31
0

Didn't get to the bottom of this, i installed Charles Proxy for OS X and on each devices settings i set the proxy details to be that of the mac when running internet sharing. worked a dream..

0

Mine turned out to be a DNS issue. Before figuring it out, I tried lots of other troubleshooting (turning Internet Sharing on/off, restarting all computers, deleting network interfaces). Here's how I fixed it:

  1. My Mac Mini is running Internet Sharing.
  2. My MacBook Pro (MBP) is connected to the Mac Mini.
  3. The MBP could connect to internet content, but not to external content. If could connect to Google in Safari by using Google's IP address (for me it was 216.58.218.174).
  4. This let me know I had a DNS problem.
  5. On the MBP, I opened System Preferences / Network / Wi-Fi.
  6. Clicked on Advanced and went to DNS.
  7. The address for my Mac Mini was listed as the DNS Server. I instead entered the address of my internet router box that actually connects me to the internet.
  8. Once I hit OK, my MBP was able to connect to everything again like normal.

UPDATE

The steps I outlined above fix the problem for the single client computer. If you have multiple devices (like your iPhone) connecting to the Mac Mini, you'll have to apply similar steps to each device.

My Mac Mini happens to have OS X Server running on it, so I was able to fix the problem at the source. I turned on the DNS server and told it to forward DNS requests to my internet router's IP address. That fixed the DNS issues for all devices that connect to Internet Sharing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .