0

On my iPhone running iOS 7, I can only set auto-lock times of up to one hour. My son's can have an auto-lock time of up to three hours, and there's no obvious difference between our two phones.

Simple guides such as eHow don't make any mention of any advanced option. How do I enable longer auto-lock times?

1

As described by Apple, they fixed a security flaw in iOS 3.0.1:

An administrator of an Exchange server has the ability to specify a "Maximum inactivity time lock" setting. This requires the user to reenter their passcode after the expiration of the inactivity time in order to use the Exchange services.

Long story short, it's because of your Exchange email account. If you have administrator access to your exchange server, you can change the mentioned "Maximum inactivity time lock" setting. As described by this page it's changed by

  1. In the console tree, navigate to Organization Configuration > Client Access.
  2. In the work pane, click the Exchange ActiveSync Mailbox Policies tab, select an existing mailbox policy, and then click Properties in the action pane.
  3. Click the Password tab.
  4. Select the Require password check box.
  5. Select the Time without user input before password must be entered (in minutes) check box.
  6. Enter the inactivity time-out value in minutes.
  7. Click OK.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .