8

I enabled the full disk encryption or at least I think so. The HD shows up as "Encrypted Logical Partition" in Disk Utility.

When I boot up the macbook however I can choose between logging in as Andreas Bonini - with my user account password - or entering the disk password.

If I choose the former option, I am never asked for the disk password.

This is not what I had in mind -- I wanted something like TrueCrypt, where everything on the disk is encrypted and the only way to access it is entering the disk password; the macbook shouldn't even be able to know what user accounts if any are present before unlocking the disk.

My user account password is obviously considerably less secure than the disk password.

2

You can remove yourself from being able to unlock the disk:

sudo fdesetup remove -user username
  • I am the only user on the machine and I get the following message when I try to remove myself: Error: Unable to remove user with the uuid '<idhere>'. – SunSparc Apr 8 '16 at 20:29
  • 1
    I wanted the exact opposite of OP’s question (still slightly related): after I restored files from a backup the system prompted me for the FileVault password and for the user account password on boot and I had to enter two passwords. I consider my user account password to be safe enough and I wanted to let this specific user to be able to automatically unlock a FileVault volume. You can do this on the Terminal with the command: sudo fdesetup add -usertoadd username. You can then check it with sudo fdesetup list. – Rafael Bugajewski Jun 5 '17 at 7:51
  • Please be very careful with this command! It broke the disk password so I couldn't unlock it afterwards and on boot it just shows a no-entry sign. I had to reinstall macOS because I ran this command. May be because it has a T2 chip. – MorbZ Nov 23 '18 at 20:52
-1
  1. Goto System Preferences
  2. Open Security & Privacy
  3. Select the FileVault tab
  4. Turn Off FileVault

I had the same issue. This fixed it.

  • 1
    This does not answer the question. – dwightk Apr 21 '15 at 19:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .