0

I got a new MacBook Pro and used a Time Machine backup to set up the new computer. It didn't import my Contacts for some reason, so I used the old laptop to send everything to iCloud, then reimported it to the new computer. That gave me all the cards, but I have two new errors:

1) Birthday notifications are shown excessively. I close them and a few minutes later I get another one. This is both the day before and day of the birthday.

2) When in FaceTime, initially I can see all the contacts I have available, but after I click on one, and then go back to All Contacts, I have a list of "no name" only.

Both of these errors, I think, would stem from the contacts app itself. iCloud seems to be involved - I suspect every time iCloud is pinged for updates, I get the birthday notification re-displaying. So I tried to restore the Contacts list to see if that would help, but I can't - when I try to open a saved .abbu, nothing happens. If I try to import just one vCard, nothing happens. I can delete the whole Contacts list, shut off iCloud, but still nothing happens when I try to reimport.

When I first set up the laptop, I also had an error 513 which would crash Mail, which I eventually found was because the permissions were wrong on Containers/com.apple.mail... in the ByHost folder, so I couldn't edit the files in there. I thought maybe the same was happening with Contacts, where it just wouldn't update my contacts because it wasn't allowed. But in the ByHost folder, all I have are 2 alias files which are trying to point to files in the same folder, but they don't exist. I tried deleting the aliases to force Contacts to make new files, and it just makes new aliases which still point to non-existent files. I tried to check the Time Machine backup but it looks like there were only ever the two aliases in that folder, no valid files.

Completely turning off iCloud and then restarting it also didn't help.

Any ideas? I have no clue at this point why I can't get my Contacts to import an abbu, whether or not iCloud is on. Which means I still haven't figured out why FaceTime is buggy and I get excessive birthday notifications.

  • how did you export/import the contacts? as vCard or archive – Ruskes Sep 14 '14 at 18:13
  • I've tried both. – LighteningKid Sep 14 '14 at 19:00
  • Did you run Look for duplicates and errors in contacts. it is somewhat sensitive to that. – Ruskes Sep 14 '14 at 20:30
  • There are no duplicates, but I just double-checked right now anyway and Contacts confirms that. – LighteningKid Sep 14 '14 at 21:07
0

Unfortunately, once Yosemite was installed, even Finder wouldn't open. I had to travel to the nearest Apple Store where even the Mac Genius was pretty stumped. His best guess was the build of Mavericks was corrupt on the new laptop to begin with, or the build number was invalid for some reason. It's not clear why that didn't fix itself when Yosemite was installed.

In short, the only solution was to do a full backup, completely wipe the system (completely - there was no data on the SSD at that point), reinstall Mavericks, upgrade to Yosemite, then copy the files from the backup without restoring any settings or preferences, and then set up each program individually from scratch.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .