3

After updating a 10.8 machine to 10.9, the standard user folders--"Documents", "Downloads" and so forth--have lost their special icons and now appear with the generic folder icon.

Interestingly, if I create a new user, the new user's icons appear as expected. Any ideas as to why this is happening, and how I can restore the default set of icons for this user?

1

Fix:

Restore the default icons
1. Go to the info view of each folder.
2. Click at the icon in the top left corner
3. Reset the icon via Command ⌘+X

Workaround:
You can copy a folder icon to another folder.

There is a solution to bring the folder icons back:
1. Create a new user
2. Go to the user folder of the new user
3. Select the Documents folder
4. Create a new folder with on an USB stick or at some location that can be accessed from both users (You can also create the folder in /Macintosh HD or however your OS X installation partition is named)
5. Open the Info view of the Documents folder (via Command ⌘+I or via File -> Get Info)
6. Open the Info view of the folder you created
7. Tap on the folder icon displayed in the top left corner, left to the Folder name (It should be surrounded by a blue line)
8. Copy the icon via Command ⌘+C
9. Tap on the folder icon in the Info view of the folder you created and place the icon there via Command ⌘+V
10. Do these steps for all folders in the users directory that have lost their icon
11. Switch back to the user with the missing icons and paste the icons of the folders you created into the folders inside the users directory

I hope that I explained these steps well enough. If you have any questions, just write a comment under this answer

Please notice, that if the folder icons get changed in future versions of OS X (like in Yosemite), you will have to go through these steps again in order to get the new icons

  • 1
    Do you know of a fix, rather than a workaround? I'd rather avoid setting custom icons; rather I want OS X to recognise that these are special folders and apply the default set of icons. – Nick Hutchinson Sep 14 '14 at 9:45
  • @NickHutchinson I added a fix that should work. – 130e13a Sep 14 '14 at 9:55
0
/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources

Here is where all the icons are. You can Get Info on a folder, say Documents, and drag any icon to replace the generic one.

The reason you lost the "special icons" in your home folder is that /User/yourusername/.DS_Store file is corrupted/missing/read-only/others. Dot-DS-dash-Store is a hidden file where all the metadata about the folder is stored. It's the reason why if you can return to a folder with icons, sorting order, positions, and other preferences just like the way you left it.

When you install OS or create a new user home folder, an appropriate .DS_Store is created. Your system failed to do that at that one instance. Unfortunately. there is no way to edit .DS_Store.

  • 1
    I don't think the default folder->icon associations are stored in ~/.DS_Store -- I tried deleting this file and rebooting for another user whose icons were appearing correctly, and it didn't have any obvious effects. – Nick Hutchinson Sep 14 '14 at 9:44
  • Did you "killall Finder"? Osx has a very robust caching scheme. If you delete and navigate right back to the directory, the system will simply recreate the exact same file from memory. So, 1. Close Finder Windows 2. rm ~/.DS_Store 3. killall Finder – fartheraway Sep 14 '14 at 11:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .