46

I am running OS X 10.10, Yosemite, and there is one feature which really annoys me. I know it must be useful for a lot of people but it's just not for me.

When I open a PDF document and, by habit, I keep clicking on the text while reading it. There are some areas where Preview thinks I would like to insert text.

Preview screenshot

As soon as this happens, the PDF document is marked edited in the title bar. When I close the document, it saves (or tries to save) it, changing the modify date and other side-effects such as triggering the DropBox sync etc.

I have accidentally inserted some text in many documents because Preview doesn't ask before saving the modified copy.

I would like to disable all PDF editing features unless explicitly invoked. Is it possible to do that?

  • 1
    This behaviour is already there in mavericks (the previous version of OSX) so it is not very much off-topic imho. – Gyom Sep 15 '14 at 13:52
  • 2
    nominated for re-opening since this is still the behaviour in the now-released Yosemite (not to mention has been an existing issue in previous versions) – drfrogsplat Oct 30 '14 at 5:22
  • 1
    This is just so terribly annoying. My crafted page numbers completely disappear once it starts "editing". – crazysim Jul 22 '16 at 18:47
  • 4
    Two years later, still the same problem... (on El Capitan) Do people at Apple use their own product? – Arthur Oct 25 '16 at 21:26
14

According to me, the best way to resolve this, is to go to System Preferences -> General. Make sure "Ask to keep changes when closing documents" is selected.

General preferences panel

This will prevent accidental changes in PDF files, as well as other files when opened by other apps.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jun 21 '16 at 12:56
  • This option doesn't seem to be available on Preview 9.0 (909.12) on Sierra 10.12.2. – flyboy777 Jan 14 '17 at 14:39
  • It works on Sierra 10.12.6. Don't know about earlier versions. – Jacob Sep 26 '17 at 15:41
  • Works on El Capitan 10.11.6 -- thanks for posting! – Jason S Jan 21 '18 at 18:42
13

Rectangular Selection Tool

A pretty poor solution to this is change the selection mode from Text Selection to Rectangular Selection in the Tools menu.

Tools menu: selection mode

This stops you inserting random text fields, but also prevents you from selecting text, which may be equally annoying.

Locking the Document

If the document has been saved*, you can lock it...

* (there is a state for temporary files, e.g. email attachments you've opened directly from the email in Apple's Mail.app, where they are aware they're a temporary file, so pressing Save opens up a Save As dialog, and you cannot lock the document)

Locked document

However, while this prevents you from editing it, if you now click in one of those places that results in a new text field, you get a rather annoying pop-up dialogue asking if you want to unlock or duplicate the document:

Locked document: unlock/duplicate dialogue

So this too is not an ideal solution, because it interrupts you perhaps even more than the inadvertent-text-entry-box, but technically prevents you from editing it if the Dropbox sync or similar is the main concern.

Apple Feedback

I suspect there isn't a simple way of disabling/re-enabling the auto-form-filling features of Preview (which are amazing when you want them!), so would suggest you send feedback to Apple on this one.

6

I have the same habit of selecting text as I'm reading. If I change anything by accident (I also tend to shuffle pages) I just push Cmd-Z and the page status goes from Edited back to Normal. I just tested this with a file in Dropbox and it didn't fire (i.e. it’s not saving the document if you undo before closing the window).

Not perfect, but it works for me.

  • Cmd-Z reverts back the possibly inserted text, but does not remove the text input box, nor does it set the status back to Normal for me. Also, the Edit->Undo menu is greyed out. – fishinear Nov 24 '15 at 14:25
  • 1
    @fishinear: If you first unselect the text box (by clicking outside it (and hoping you don't create a new text box by that)) the undo should work as described. – siegi Nov 14 '16 at 6:12
1

The issue here is largely caused by Apple's change to the Document model introduced in Lion, with changes to the document being auto-saved. While this behaviour is desirable in, say, a Word processor, it's not so desirable in an app like Preview, which is often used for Viewing originals that should not be edited.

You can turn off Apple's Auto-save in Preview with the following Terminal command:

defaults write -app 'Preview' ApplePersistence -bool no

As a result, if you accidentally click on the document and create a Text Annotation, the change will not be saved unless you manually save the document.

-4

Go under File->Print, choose Save as PDF in the drop-down PDF menu in the lower left corner of the dialog box. Works like a charm.

  • 3
    How does this disable editing? – Mark Jul 13 '15 at 10:13
  • Saved file is going to be uneditable. Try it, when that worked please get back your downvote. – alwaysprep Jul 13 '15 at 13:15
  • 6
    @alwaysprep This answer doesn't work. I think you've misunderstood the question. – Will Vousden Aug 31 '15 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .