2

I've my column in format dd/mm/yyyy and I would like to sort them by date. But I can't find any way of sorting the column by date. If I Sort Ascending, it doesn't recognise that the rows have the date formats. Any easy way of doing that?

  • What is the format ? is it date ? – Ruskes Sep 11 '14 at 19:39
  • Yes, it's a date in format dd/mm/yyy (e.g. 10/12/2012, 18/02/2013, 10/12/2012, etc). – kenorb Sep 12 '14 at 11:53
3

Your dates might not be recognized as dates by Numbers.

In my case, Numbers does not offer dd/mm/yyyy as one of the standard date format and I have to define a custom format for that pattern. (Not sure, if that applies in your case: The date must be entered according to your locale settings - I can set "dd/mm/yyyy" as the date format, but I have to enter it as "dd.mm.yyyy" on my German system.)

Using the sort & filter window then works well on the formatted dates.

  • ...moreover, if those dates came from a csv or similar text source they will look as if recognised but they are not: one way to find out is to fake edit one cell, adding a space and typing enter, this will trigger something in numbers and you will see the alignment changing (from something to right), that sorted it for me. – Edoardo Dec 19 '17 at 8:42
  • 1
    I just had the same issue and found that if I selected the date column and changed the date 'format' then tried to sort them again, it sorted correctly. Like @eddyce mentioned about csv, possibly it looks correct but needs to be reformatted for numbers to identify it correctly – doz87 Jan 2 '18 at 4:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .