I have an eMac (PPC G4) with 512 MB RAM, running 10.5.8. When I run Software Update, the "Checking for new software..." process never completes. I have tried deleting my /Library/Caches/com.apple.SoftwareUpdate/Cache.db and running Software Update again, with no luck. I have also tried Repairing Disk Permissions from Disk Utility, and that hasn't worked either. Both of those suggestions I got from here

Any suggestions??

  • 4
    Have you tried running it from the command line? softwareupdate --list to see if it spits out any errors? – Chealion Sep 11 '10 at 21:59
  • 1
    Yep I tried that too. Just freezes just like the GUI – Thomas Sep 12 '10 at 19:49
  • Also an output from your Console would be helpful to see where the problem might be. – Martin Marconcini Sep 12 '10 at 20:02
  • There is no console output. It just freezes and does not complete lol – Thomas Sep 14 '10 at 13:05
  • 1
    Have you tried creating a new user account and executing the Software Update from that new user? – Martin Marconcini Oct 15 '10 at 11:27

Try moving the contents of /Library/Receipts somewhere else. I have seen some weird problems caused by corrupted files there a couple of times. Also make sure apps like Little Snitch do not intervene in the process.


Do it the CLI way:

sudo softwareupdate -i -a

this may help to get more verbose output.

  • 1
    Thanks for the reply. This freezes as well, right after the command is issued. – Thomas Oct 18 '10 at 21:28
  • 2
    right after? nothing like Software Update Tool Copyright 2002-2009 Apple ?? alternatively, if you man softwareupdate you'll get a list of options, like a simple sudo softwareupdate -l listing and even more useful sudo softwareupdate -v -i -a to have a verbose output – meduz Oct 21 '10 at 19:26
  • 1
    well, yeah I get the 'Software Update Tool' info, but it freezes after that. I believe I tried the man softwareupdate but I don't remember what happened lol. I definitely didn't try with verbose output. I'll try that later. Thanks! – Thomas Oct 28 '10 at 18:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .