3

I don't use my .signature by default, but often add it to a message after generating the reply. In these cases, is there any way to get the signature to appear above the quoted text? I have the option selected in Mail preferences, but it still always puts it at the bottom of the message anyway.

enter image description here

I am running Mavericks now, but it has always [mis]behaved this way.

3
  • If you have no signature to choose from how do you add it?
    – Ruskes
    Sep 8, 2014 at 17:37
  • @Buscar웃 I have signatures :^) I just had the All Signatures profile selected when I took the screen grab.
    – beroe
    Sep 8, 2014 at 19:01
  • This should work just fine... What do your Composing preferences look like in Mail?
    – sdmeyers
    Sep 8, 2014 at 19:10

1 Answer 1

5

It is correct that you can not choose signature after you started the reply using the "None" for Signatures and if you only have one signature on file.

It will Automatically use NONE if that is your original setting in signatures.

Here is my work around that:

First the solution will allow you to normally start replies without Signature.

If you now decide to Sign, you will have the option to choose a Signature.

To do that you just make a empty Signature in the Mail Preferences Signatures, using the + to add and name it something other than none (I called it test)

Now you should have 2 signatures to choose from.

sign

Your original and the new one containing nothing.

In Signatures window choose the new one as default.

Now in replay to email, you will have no signature by default, but you can switch to the actual signature and it will be on the top of the Quoted message.

signat

4
  • Very clever! Thanks. (Congrats on almost reaching 10k!)
    – beroe
    Sep 8, 2014 at 22:14
  • 1
    You are welcome and than you, lots of hard work and may failure, but learning fast at age of 65 :)
    – Ruskes
    Sep 8, 2014 at 22:15
  • Me impresiones.
    – beroe
    Sep 8, 2014 at 22:41
  • I had read this answer but didn't quite understand. Now I see that the workaround is to create a new blank signature and make it the default. Then while composing you can select the signature you really want. Jan 15, 2020 at 21:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .