2

My friend gave me a USB key that has Windows Viruses on it.

On my mac, when I try to delete them it fails and tells me that those files are "locked". I ran an anti-virus, which also was unable to delete them for the same reason.

  • I think I found the answer. In the command line I typed "sudo rm filename". – nute May 19 '11 at 8:34
4

There are two options for files that came from a Windows drive:

  1. Right click on the file and select "Get Info" (or mark all files and press command + alt + i) to get the file information. There in the "General"-tab you can find and opt-out the "Locked"-option. Trash and delete them.
  2. Open /Applications/Utilities/Terminal.app and type cd /Volumes/YourDrive, then rm -r thefile.exe. If that fails, try sudo rm -r thefile.exe and enter your password.

Mac has other steps if you can't unlock the file - see this article - TS1402 for details on immutable flags and if the directory permissions won't let you modify a file. The two above steps handle the vast majority of locked files on the mac.

  • I could not uncheck the "locked" option, but the "sudo" worked. Thanks – nute May 21 '11 at 17:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .