2

Mounting NTFS drives works in OS X natively. Mounting drives with fstab is common and can be seen here and here and here.

I was able to successfully do it with the following addition to my fstab.

UUID=30ADE88E-0889-42FF-AEC3-3AE0D11C7FE4 none ntfs rw,auto,nobrowse

However, on reboot the next time I plugged in my drive it no longer worked.

I tried sudo mount -a but that failed with the following error:

mount: realpath /none: No such file or directory

The diskutil command is my go-to for finding drive information.

➜  /  diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS 512ssd                  499.4 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *1.0 TB     disk1
   1:               Windows_NTFS 900GBWD                 900.2 GB   disk1s1 <--- SEE
   2:             Windows_FAT_32 100GBWDFAT              100.0 GB   disk1s2  

Once you know your drive location in /dev then you can find the UUID with diskutil info disk1s1:

➜  /  diskutil info disk1s1
   Device Identifier:        disk1s1
   Device Node:              /dev/disk1s1
   Part of Whole:            disk1
   Device / Media Name:      Untitled 1

   Volume Name:              900GBWD
   Escaped with Unicode:     900GBWD

   Mounted:                  No

   File System Personality:  NTFS
   Type (Bundle):            ntfs
   Name (User Visible):      Windows NT File System (NTFS)

   Partition Type:           Windows_NTFS
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported
   Volume UUID:              30ADE88E-0889-42FF-AEC3-3AE0D11C7FE4

   Total Size:               900.2 GB (900174610944 Bytes) (exactly 1758153537 512-Byte-Units)
   Volume Free Space:        0 B (0 Bytes) (exactly 0 512-Byte-Units)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (not mounted)
   Ejectable:                Yes

   Whole:                    No
   Internal:                 No

However, I'm not sure why the fstab isn't working anymore or how I can correctly mount this drive. How do you mount a NTFS drive as writable in OS X?

2
  • Just readable? OS X allows you to read NTFS without using fstab. Sep 6 '14 at 17:02
  • Sorry, I ment "writable" :)
    – Xeoncross
    Sep 6 '14 at 17:06
1

You don't. OS X does not have reliable r/w support for NTFS.

Purchase one of the reliable solutions, such as Paragon, or Tuxera.

1
  • 1
    Source? Many people claim works fine.
    – Xeoncross
    Sep 8 '14 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .