1

I would like to SSH onto a remote linux computer from the internet at school, which does not support port forwarding.

I type ssh root@<myipadresshere.com

but of course it fails.

Is there a way to SSH to my remote server using any network I am connected to without the ports being forwarded?

If I type SSH -A root@MyIP , it times out.

Skylers-MacBook-Pro:~ skylerfennell$ ssh -vvv root@kd0whb.duckdns.org
OpenSSH_5.9p1, OpenSSL 0.9.8y 5 Feb 2013
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to kd0whb.duckdns.org [67.166.55.176] port 22.
debug1: Connection established.
debug1: identity file /Users/skylerfennell/.ssh/id_rsa type -1
debug1: identity file /Users/skylerfennell/.ssh/id_rsa-cert type -1
debug1: identity file /Users/skylerfennell/.ssh/id_dsa type -1
debug1: identity file /Users/skylerfennell/.ssh/id_dsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9
debug2: fd 3 setting O_NONBLOCK
debug3: load_hostkeys: loading entries for host "kd0whb.duckdns.org" from file "/Users/skylerfennell/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /Users/skylerfennell/.ssh/known_hosts:6
debug3: load_hostkeys: loaded 1 keys
debug3: order_hostkeyalgs: prefer hostkeyalgs: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa
debug1: SSH2_MSG_KEXINIT sent
Write failed: Broken pipe


Skylers-MacBook-Pro:~ skylerfennell$ ssh -a root@kd0whb.duckdns.org
    ssh: connect to host kd0whb.duckdns.org port 22: Operation timed out
  • Note that options can be implied by /etc/ssh_config and ~/.ssh/config -- have you checked those files to make sure the type of forwarding you're explicitly trying not to do isn't enabled by default? See: linux.die.net/man/5/ssh_config – Ian C. Sep 8 '14 at 16:59
1

are you referring to port forwarding or agent forwarding? By default, port forwarding isn't enabled unless you use -L or -R options.

Agent forwarding (for authentication using keys in your local ssh-agent) can be enabled by using

ssh -A <user>@<host>

Let me know if this is helpful.

  • Ok, well I won't be able to tell you until Monday – Skyler 440 Sep 6 '14 at 3:12
  • Did it work for you? – webmarc Sep 9 '14 at 16:39
  • Nope, it timed out. – Skyler 440 Sep 13 '14 at 16:21
  • I think the network is restricting outgoing on 22 – Skyler 440 Sep 13 '14 at 16:22
  • Try with -vvv and post the debug output so we can diagnose. – webmarc Sep 13 '14 at 18:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .