1

I want to disable the interactive line wrapping that iterm does in my terminal application.

I can run

$ python -c 'print "\x1b[?7l"'

to disable line wrapping on output, so long lines like

$ python -c 'print "asdf"*100'

don't immediately get line wrapped and instead are cut off, but once I interactively change the window width to be smaller that line still wraps. I'd like behavior like vim has when in set nowrap mode - not even a flicker of a wrap.

This question is similar to Disable line wrapping for output in the Terminal, but that's asking about scrolling.

  • Ah, I now believe this is only possible by using the terminal fullscreen mode, something like python -c 'print "\x1b[?1049h"' – Thomas Sep 4 '14 at 18:49
1

I believe this is not possible without using fullscreen mode - vim is using fullscreen mode (python -c 'print "\x1b[?1049h"') which disables vertical scrolling as well, which isn't what I want (though this wasn't clear in the question).

Also, it turns out this behavior isn't specific to terminal.app - it's how all the terminals I've tried work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .