4

I have an iPhone 4S currently running ios7.0.4. I have been using the built in Mail app since I bought my phone years ago and it has always worked fine. I have two accounts set up in the app. Recently (within the past month, maybe two) when I open the app, I am met with the Welcome/set-up screen that lists the different account types that you can set up (iCloud, Exchange, Google, etc.) even though I already have my accounts set up and they were working that morning. If I double-tap the home button and swipe up to close the app, and tap the app again to re-open it, it loads both accounts like normal.

This wouldn't really be too big of an issue because it has a quick fix, however because it doesn't recognize that a mail account is set up, it also does not alert me when I receive a new email. So I have to manually check my emails every hour to make sure I don't miss anything.

While the mail app is being weird and showing me the welcome screen, I can open up the mail settings and still see both accounts that I have, and notification settings are all as they should be.

Either I don't know how to phrase the questions properly to get hits on Google, or no one else has ever had this issue. Has anyone heard of this, or have any suggestions?

2

Thanks for the suggestions, tried both with no luck, then I actually went in and made sure every setting was set the way I expected them to be set.

Somehow, without my doing, the settings had been changed. I noticed this once before, my phone crashed and all of my custom ringtones/vibrations were unset for my contacts. Not lost, just unset.

In case someone reads this and is still wondering what settings you've missed, the particular settings that I had to fix were:

Notification Center > Mail > (Account) >
1. Alert Style [Alerts]
2. Show on Lock Screen [Yes]

I'm sure we all have those moments when the most obvious solution just can't be it and there's no point in checking because you're SURE there's NO WAY it could be it... oops :)

  • thanks, fixed it for me to go to Settings > Mail,Contacts,Calendar > select my mail account and enable Mail – Loknar Feb 6 '15 at 11:50
  • The answer doesn't really help (Notification Center?), this comment did. Suggest an edit to the answer – ijustlovemath Oct 10 '18 at 19:49
1

This happened to me today as well. I put it in Airplane mode, restarted, then turned off Airplane and voila!

1

Screenshot tutorial

Wow I can't believe that was so easy!

0

This worked for me ... Settings > Mail,Contacts,Calendar > select my mail account and enable Mail – Loknar Feb 6 '15 at 11:50 I had deleted iOS Apple mail app to try alternative. Re-installed and had this problem. Under settings accounts were all there from before but mail needed to be enabled.

0

You could have just disabled the mail feature in the icloud settings. To fix this you will need to go to Settings, Mail, Accounts, iCloud or your previous account, then tap on Mail and enable it on. I too had this problem and I didn't know what was wrong till I searched for it on my own. :)

-Zach

0

Most of the above I tried didn't work. Wasn't about to reset the phone either...Took a shot and went to settings, switched to airplane mode, tried mail and it opened up like it should, went back to settings, turned off airplane mode, and still good-so turning airplane mode on then off fixed the problem (can't imagine how but it did)

-2

Just do a BASIC reset of iPad, that worked for me. D

  • Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. If possible, it'd be good if you could add some more info, such as what you mean by a basic reset and how you go about doing that. Also, you may want to read How to Answer for tips on providing answers here. – Monomeeth Apr 23 '18 at 11:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .