5

I have created a Numbers spreadsheet containing a set of data including email addresses.

Some of these addresses appear as hyperlinks, and I can't seem to edit or change them.
Every time I try to select one it jumps to my Mail application.

I have tried to change formatting to "Text", but this seems to have no effect.

10 Answers 10

2

If you can edit each item to touch them,

  • go to Edit -> Substitutions and uncheck SmartLinks.

All new entries will not change and by touching the old cells, your problem is solved. (FYI, works the same in Pages as well).

2
  • This is the closest to a solution. It doesn't fix existing links, but fixes new pastes.
    – Milliways
    Mar 21, 2020 at 9:52
  • If you want to fix existing links, copy and paste them into TextEdit (make sure it's in plain text mode and not rich text mode), then copy and paste them back into Numbers. The formatting will be lost. Apr 17, 2020 at 1:47
5

In the Numbers 3.5.3 this is extremely difficult to do. Thanks to @Vev for giving me the hint to discover how to do it.

  1. First: expand the size of the cell so there is some white space around the hyperlink.
  2. Click once in the white space to select the Cell.

  3. Click once again in the white space, to enable the Text Cursor.

  4. Right-Click on the hyperlink, which selects it and provides a context menu. (If you don't have right-click enabled, use Ctrl-click on the Mac)

  5. Select "Edit Link" in the context menu.

  6. Click the "Remove" button from the Edit Link dialog.

1
  • I was having a real problem with Step 3, the click has to be very quick. I was holding the mouse button down too long and could never get the cursor.
    – Neil
    Sep 12, 2015 at 17:35
2

Select the entire list or the portion that you want to change.

  1. Press Command ⌘ + c (to copy the entire list or the portion that you want to change)
  2. Press option ⌥ + shift ⇧ + command ⌘ + v (very quickly). This writes over with ONLY plain text in the set font and size.
  3. If anything went wrong, use command ⌘ + z to revert.
1
  • Stumbled onto this just after finding Yellowbox's menu-driven approach outlined on Apple's discussion forums: "... you can select (say) a column or row of hyperlinks, Copy, then Menu > Edit > Paste and Match Style. That will remove those links and replace them with text." Jan 16, 2021 at 6:29
1

Highlight the entire link. Then use Format/Remove link.

1

In older versions of Numbers, it is necessary to cut and repaste the hyperlinked line (with the AutoCorrect option mentioned already turned off.) Select the line, cut it, then paste it. It will then be pasted without hyperlinking.

This will be necessary even to edit the line. This is because clicking on the line to edit it will only perform the hyperlink action. This is a seriously amazing failure on someones part at Apple. The fact that this went unaddressed for years, unfortunately, is par-for-the-course for Apple.

1

I have a spreadsheet where all the cells in one column contain the hyperlinks. I select and copy that column and pasted it in a new Excel spreadsheet. Went to Edit / Clear / Hyperlinks. Then pasted it back into my Numbers document. That may be cheating, but that works.

1

The solution is for me:

  1. Select cells or column you want to correct and apply Cut command (Command ⌘ + X)
  2. With these cells still selected, go to Text Tab and Select predefined style for cells. This is important because if you don’t do that, each cell memorizes text style and treat it like hyperlink style cell.
  3. Paste with same style (Option ⌥ + Shift ⇧ + Command ⌘ + v)
0

If you have a long list of entries (some of my spreadsheets have 300+ entries and the emails are always hyperlinked!!) here's what I do:

  1. Copy the column of emails into a text editing program such as bbedit.

  2. replace instances of '@" with at - or really any unique string

  3. I also do the same thing with the dot - replace '.' with DOT

  4. Then I paste the result back into the column (making sure they're in the correct rows.

  5. If I want to use the list to send out a mass email, I just do the same thing in revers: Copy the column into bbedit and replace at with '@'.

A pain but easier than doing each formatting by hand.

It's really stupid of Apple and it should be changed.

0

In Numbers '09 (version 2.3) there is much easier way. Select all of the cells that you which to remove hyperlinks from, im my case Command+A to select everything. Then open your Inspector. In the second tab from the far right called "hyperlink", at the bottom there is a checkbox called "Make all hyperlinks inactive". That's it!

I hope this is helpful as I'm so glad I found this!

1
  • Not sure if the discussion is about Numbers '09 or not, but it can't really hurt.
    – JMY1000
    Jun 15, 2016 at 8:54
-1

Cut column content with Command X, then paste without formatting by using CommandShiftV .

These are not dedicated Numbers but general Mac shortcuts.

1
  • What does that do? I can't find it in the list of Numbers Keyboard Shortcuts. Consider expanding on your post as to why you think it's correct. Oh, and Welcome to Ask Different.
    – Allan
    Dec 30, 2017 at 13:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .