2

I am developing my first ever iOS mobile app. I am using OS X Lion 10.7.5 with Xcode 4.6 for development. I completed my app and now want to test on a device. When I am trying to connect iPad Air with iOS 7.1 for testing, Xcode is giving an error:

Xcode cannot run using the selected device. No provisioned iOS devices are available with a compatible iOS version. Connect an iOS device with a recent enough version of iOS to run your application or choose an iOS simulator as the destination.

I googled and came to decision that I need to use Xcode 5 if I want to test device with iOS 6.1 and above but I cannot install Xcode 5 as it requires OS X 10.8.4 and above. I decided to upgrade my OS from Lion to Mavericks.

Just wanted to know if I do so will it create any problems in my already developed app? I don't have time to take a backup with Time Machine.

1

This doesn't seem to be a problem with your version of Xcode/iOS/OS X, but rather that you have not provisioned your device. You need to add your provisioning profile to the device to allow you to test apps on it. Newer versions of Xcode will do this for you, but you can still do it with older versions yourself in the Member Center.

1

I had the same problem on Xcode 6.3 after updating a phone to iOS 8.3. Downloading the provisioning files didn't fix the problem, but I stumbled onto a solution:

Connect the phone to your mac and run iTunes. iTunes will ask if you want to trust the phone. Answer yes on the phone and then the Xcode error goes away. I tried it on a second phone, and it worked on it too.

  • iTunes & tap trust fix my problem ~ – JerryZhou Aug 10 at 1:40
0

I had the same problem and, geez, I nearly freaked out, what I did was to recreate all provisioning profiles in Apple's Member Center (if it only brings you to the log-in page do so and re-klick on the link) and re-download them. Also make sure that you add your desired device when creating the PP. After downloading double-klick ALL PPs which should bring up the Keychain app, you can close it afterwards again.

If it does not show up then you should plug-in your device, go to Xcode -> Organizer (or Devices if you are on Xcode 5) and activate the iDevice for development. If it is still not working then in Organizer/Devices open your device's PP section, there it should show up, if not try to add it.

One more possibility: open the link again and add your device there manually.

Then it should work again

0

Try to restart the device. Press and hold power button and slide to power off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .