3

I'm running OSX 10.9.4, and IPhoto 9.5.1. I have an old iphoto library (pre 7.0) on a time-machined backup external drive and wanted to access the photos on it.

I tried to 'Switch' to it in IPhoto, and was asked to run the iPhoto library upgrader tool (http://support.apple.com/kb/DL1523) instead.

I did that, and at some point the upgrader declared my library ready to be upgraded by the "new" version of iPhoto. I asked it to do so, and then iPhoto starts up, complaining again that the library needs to be upgraded using the iPhoto library upgrader.

This keeps happening. What's worse, the Option/Alt trick to switch to a new library at iPhoto doesn't work, so once I've told iPhoto once to switch to the new (non-working) library, I can no longer run iPhoto unless I dismount the external drive.

Any suggestions would be greatly appreciated. I've also tried the Option-Cmd-start iPhoto attempt to repair the library, and that doesn't pop up any repair screen either.

Notes (based on other discussions on the web):

  • the external drive is formatted Mac OSX extended (journaled, case sensitive)
  • I can't use Time Machine directly since this backup is from a different machine.
  • I have NOT tried first copying the library to the local drive, but I doubt that would make a difference.
  • This is exactly the same problem I'm experiencing, did you ever find a solution? – jvans Mar 23 '15 at 0:45
  • It was a while ago, but I don't think I did. – Suresh Mar 25 '15 at 5:11
1

After a fair number of tears thinking apple had stolen a decade of my photos, I found a work around too which might be the exact same thing jvans said, but brought down to my novice level.

Right click on the iPhoto Library that won't open, and go to "show package contents"---
inside there is a folder called "Originals" that holds the actual .jpgs of the images
Copy this entire folder out onto the hard drive. Then, you can import the whole folder into your new "iphoto" or "Photos" library, or just have them for future use on your hard drive. Not ideal, but much better than losing your entire library.

0

You can workaround the issue by copying your pictures from the command line and reimporting them.

cp -R /path/to/iphoto/originals (<---pictures stored in this directory under iphoto) /path/to/new_folder

reimport old photos to new version. This is definitely not ideal but it works for anyone else who runs into this issue

0

I had this problem when trying to upgrade an old iPhoto library that I had long ago moved to an external drive.

The solution for me was to restore the iPhoto Library (from backup! because the tool had corrupted the original on the external drive!) to its standard location as /Users/<you>/Pictures/iPhoto Library, then run the upgrade tool again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .