0

I'm connected to WiFi but won't connect to the Web. FaceTime works but when I try to load safari the bar starts to fill and then stops. I've checked DNS and tried 8.8.8.8 as well as the defaults. All proxies are unchecked. I've run diagnostics and it says it's working fine. Can anyone help?

  • Couple of questions to make this more specific and easier to debug - is this any wifi, or your specific access point at home? What if you try a different WiFi network? What about another device on the same WiFi network? Have you tried a wired connection and does it work? What about another browser? – Alex Aug 31 '14 at 1:43
1

I've asked some questions to help debug as a comment, but this is what I would try:

1) Turn off all extensions in Safari (Safari menu -> Preferences -> Extensions)

2) Rule out DNS issues - try to ping a site. Open Terminal (in Applications -> Utilities). Type in:

ping google.com

You should get something like:

⇒  ping google.com PING google.com (173.194.43.39): 56 data bytes
64 bytes from 173.194.43.39: icmp_seq=0 ttl=251 time=7.462 ms
64 bytes from 173.194.43.39: icmp_seq=1 ttl=251 time=6.895 ms
64 bytes from 173.194.43.39: icmp_seq=2 ttl=251 time=7.991 ms

So, take the IP (173.194.43.39), might be different for you, and put that into Safari, see if that works.

You can also just try the IP above as well. If Safari works with the IP, then the issue is DNS.

3) Using Terminal again, try curl:

curl www.google.com

If you get a lot of code back, it's fine, and your issue is purely Safari.

4) Try a different WiFi network 5) Try a different device on your WiFi network 6) Try a different browser if you have one

| improve this answer | |
  • Its any wifi. I used my phone as a wifi Hotspot same thing. Also, all of the other devices in my house work fine. – Nick N Angel Echcaroff Aug 31 '14 at 8:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .