5

How does one disable Google Chrome from using WebGL on a Mac (Mac OS X 10.6)?

(There currently appears to be some sort of security advisory regarding this component.)

5
  • 2
    I haven't heard of any security advisory. Do you have a source for this? – Jason Anderson May 21 '11 at 17:07
  • 1
    Ditto. I've not heard of this either. – Kerri Shotts Jun 6 '11 at 2:51
  • I highly doubt it's so serious u can't take the tiny risk of just running it normally untill it's patched – Alexander Aug 5 '11 at 1:08
  • For those inquiring about the WebGL flaw, read the following: news.techworld.com/security/3286646/… – user10355 Oct 4 '11 at 3:15
  • Another good reason to disable WebGL is to conserve GPU resources for more important things like 3D rendering or 2D image editing. Why waste GPU resources on rendering web pages if there's something better they can be used for. – Pharap Dec 15 '14 at 22:13
7

Chrome lets you disable WebGL using the about:flags page.

Type about:flags into the URL bar and press return.

Find the Disable WebGL flag and enable it. Restart Chrome for changes to appear.

enter image description here

2
  • 1
    +1, much nicer solution than 'disable-webgl' which doesn't disable it all of the time. – Nicholas Smith Oct 4 '11 at 12:23
  • 3
    Note that this switch is no longer there in current versions of Chrome. – jbchurchill May 15 '17 at 22:46
3

Well, seems that in the latest versions of Chrome this flag cannot be disabled from about:flags. In order to disable it:

  • Close chrome (if running)
  • Open the terminal.
  • Type: open -a "Google Chrome" --args -disable-webgl
  • Profit!
-1

Not sure how to do this in OS X, but you may be able to do so by running chrome from terminal with the "-disable-webgl" flag.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .