0

i am currently using mac 32 bit.I am unable to open eclipse an error pop up saying that i need to update my JVM from 1.6 to 1.7 and from the java website there are no ver 1.7 for mac 32bit. what am i suppose to do?

  • what equipment do you have, and what os x? – Ruskes Aug 29 '14 at 16:59
  • macbook pro running maverick ver 10.9.4 32bit – amirulhaziq Aug 29 '14 at 17:07
  • 2
    Did you try telling Eclipse to use the JVM 1.6 instead? If a JVM is installed in the eclipse/jre directory, Eclipse will use it. – Ruskes Aug 29 '14 at 18:16
  • 3
    Mavericks is 64-bit—what exactly is preventing the installation of JVM? – grg Aug 29 '14 at 18:54
  • 1
    Why do you think you have a 32 bit OS? – Mark Aug 29 '14 at 19:15
2

Mavericks is a 64-bit OS; it has no 32-bit option... You can run 32-bit apps in it & run 64-bit apps in 32-bit mode, but the OS itself, afaik, is only available in 64-bit.

32-bit Macs cannot run Mavericks.

Edit - 32-bit mode picture...

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .