1

My problem :

Recently I started to use a Magic Trackpad for my MacBook Air (Mid 12), and discovered some annoyance :

I regularly see some devices connected to my Mac by Bluetooth, the one that I never paired...

One of this devices is my FitBit One, which is not paired to my Mac, but still can connect and use it's (fitbit) battery...

Some others devices appear from time to time with different names, that I do not recognise... Sometimes I know when another device, that my Trackpad, is connected because the trackpad starts to freeze.

I tried to "remove" an unwanted device, but it keeps reappearing...

I can't even imagine what I can do, since the bluetooth options are really limited...

Question :

Is there some way to have an advanced bluetooth options? So I could "force" all devices to ask a permission before even trying to connect to my Mac?

I found some screenshots of advanced view here : Securing Bluetooth

But this is an old one and I am afraid that in Mavericks the only "advanced option" is limited to "alt + bluetooth" which gives nothing useful to me.

If anyone have an idea how to fix this problem (but still keep using my trackpad :) ), it would be great to share with me :)

Thank you in advance!

EDIT (29/08/14)

Some precisions : I detected this problem by seeing my FitBit One battery life going from one week to 48 hours, exactly from the moment I started to use BT on my Mac. I use my Magic Trackpad only at work, and I already checked, if I leave my Mac working all night my FitBit will loose somme battery life in one night, and my Mac is the only device with BT enabled...

Here the link where you can see my One listed as Connected, but I never paired it or was asked to. Link

  • A cursory glance at the linked article doesn't provide any screenshots of an 'advanced Bluetooth' settings panel. Could you quote/embed what you are referring to from the article? – grg Aug 28 '14 at 15:46
  • Sounds like your BT is stuck in discovery mode. Does it do that if you disconnect the Magic Trackpad ? – Ruskes Aug 28 '14 at 15:59
  • Hi. - Concerning the "advanced bluetooth", actually that was my question, because the only option I see are very limitated...but in the article it's in the midle of the page, if you search for "Securing Bluetooth" you will see the screenshot I am talking about, and in which you could see some options such as "require authentification", "encrypt" etc. - Does it do that if I disconnect the Magic Trackpad ? I could not say because the only way I know that some device is connected, is by seeing my Magic trackpad freezes. – Passing By Aug 29 '14 at 6:44
1

When you say that you see devices connected to your Mac, are you in the Bluetooth Preference Panel or are they appearing in a different app?

Normally your BT is not in discoverable mode, meaning other devices can't see/pair with it unless it has already been paired. When you open up the BT Pref Pane, the discoverable mode is automatically switched on. When this happens, it will list all of the available BT devices it can find (like your FitBit) so that you may pair with it.

If it isn't already on, in the BT Pref Pane, enable the "Show BlueTooth in menu bar" checkbox. This will add the BT menu in the right side of the menu bar. Clicking on this will show you the currently paired devices and other basic functions. However, if you hold down the Option key then click on the menu, you are shown an advanced menu. This will show you if your BT is in discoverable mode or not, which it should only be on if the BT Pref Pane is open.

If there are any devices listed in the menu that you don't want paired, choose that device's submenu and select Remove.

  • Hi, - When you say that you see devices connected to your Mac, are you in the Bluetooth Preference Panel or are they appearing in a different app? >>> I see them in BT menu bar - I checked, I am not Discoverable (off) - If there are any devices listed in the menu that you don't want paired, choose that device's submenu and select Remove. >>> That's the point...I remove them every time I see them (my One for exemple), and still they reappear in the BT menu bar. I will edit my initial post by adding some extra info about my fitbit One, it could help – Passing By Aug 29 '14 at 6:53
  • Try deleting the BT preference file with sudo rm /Library/Preferences/com.apple.Bluetooth.plist and reboot. You will need to re-pair your trackpad after the boot. – Insomniac Software Aug 29 '14 at 15:26
  • Is it normal? >>> /Library/Preferences/com.apple.Bluetooth.plist: No such file or directory. In Finder I only see this one : com.apple.BluetoothFileExchange.plist – Passing By Aug 29 '14 at 16:10
  • Usually that is not normal. The com.apple.Bluetooth.plist file should be in the system's /Library/Preferences directory and the com.apple.BluetoothFileExchange.plist file is in the user's Library/Preferences directory. Try looking in your ~/Library/Preferences directory for the Bluetooth files and delete them. If that still doesn't help, try deleting all of the com.apple.Bluetooth* files in both Library locations and reboot. That should clear out any and all BT settings. – Insomniac Software Aug 30 '14 at 19:14
  • Hi. Indeed, my bad :) I found the one we need, deleted it, rebooted...Nothing changed. Absolutely. My Trackpad is still paired, even when I deleted both files (Bluetooth.plist AND BluetoothFileExchange.plist). And I got some news...just spoted that my Mac accept other connections :) Watch this screenshot :) Some guy/girl with a Flex just connected to my Mac : tinypic.com/r/2q3zlh1/8 I MUST do something wrong... – Passing By Sep 2 '14 at 13:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .