I'm currently dual booting Ubuntu 14.04 and OS X Mavericks (10.9.4) on my 2014 Macbook Pro. When running Ubuntu, I can plug in the Ethernet cable and instantly be connected. But when running OS X, there's no Ethernet connection detected.

Since I was able to connect on Ubuntu instantly, I shouldn't have the issue of having to set up additional configurations, such as a PPoE connection. Since I'm dual booting I'm obviously also using the same laptop, the same Ethernet cable, and the same Ethernet port so it doesn't seem like there should be a hardware issue either.

What could be the issue here?

enter image description here

When I run "ifconfig" in my terminal while booting OS X, this is what I get:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    nd6 options=1<PERFORMNUD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 80:e6:50:16:b0:c0 
    inet6 fe80::82e6:50ff:fe16:b0c0%en0 prefixlen 64 scopeid 0x4 
    inet 192.168.70.245 netmask 0xffffff00 broadcast 192.168.70.255
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 72:00:05:04:94:20 
    media: autoselect <full-duplex>
    status: inactive
en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 72:00:05:04:94:21 
    media: autoselect <full-duplex>
    status: inactive
bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether 82:e6:50:61:cb:00 
    Configuration:
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en1 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 5 priority 0 path cost 0
    member: en2 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 6 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: <unknown type>
    status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 02:e6:50:16:b0:c0 
    media: autoselect
    status: inactive

After reinstalling OS X I can no longer see the rEFInd screen and thus cannot boot Ubuntu. However, I remember when I ran "ifconfig" earlier I saw an item that started with "eth0"

  • sounds like the Ubuntu is keeping the Ethernet to it self and not letting OSX have it. Check in Terminal for active connections. – Buscar웃 Aug 28 '14 at 16:13
  • When you click on the + button, you should be presented with a drop down menu with a list of interfaces. Can you post a screen shot of this menu? Can you also run ifconfig in a terminal and Application > Utilities > System Information and look at Hardware > Ethernet Cards and tell us what they display? – Édouard Aug 29 '14 at 14:36

If you can see the interface in /Utilities/System Configration > "Ethernet Cards", try creating a new network location.

If the issue persists in a new location, you can reset OS X's detected network interfaces by (re)moving /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist. If you want to play it absolutely safe, you could (re)move the entire SystemConfiguration folder, but this will affect other settings (like custom network authentication, power management settings, etc.). NOTE: this step supersedes testing it in a new user since it removes global preferences (which affect every user).

If you're still not seeing it, try booting to your Recovery Partition, launching Terminal, and running ifconfig to see if the Recovery partition can see the network interface. If the Recovery Partition sees it, a reinstall of OS X might be needed. If it doesn't, well then you did something that I've never seen... :)

  • Creating a new network location didn't change anything, nor did deleting the entire SystemConfiguration folder. I booted to my Recovery Partition, ran "ifconfig", but didn't see an ethernet connection. – jyan Aug 31 '14 at 1:45
  • Also, even though I didn't see an ethernet connection, I reinstalled OS X anyways, hoping it would help. Now, when I restart my laptop I don't see the rEFInd screen and I get taken straight to OS X. – jyan Aug 31 '14 at 2:05

You deleted your Ethernet connection. From System Preferences -> Network, hit the '+' and add a new one (it may be Thunderbolt or Thunderbolt Bridge).

  • I tried that, but it doesn't look like it changed anything- i.imgur.com/Nu7hZ6B.png – jyan Aug 29 '14 at 6:20
  • Hit apply, disconnect and reconnect the Ethernet. Are you using thunderbolt or is it an actual Ethernet port? – Harv Aug 29 '14 at 6:21
  • Just tried that, but it doesn't look like anything changed. I'm using an actual Ethernet port. – jyan Aug 29 '14 at 6:24
  • Create a new user and see if the problem persists? – Harv Aug 29 '14 at 7:43
up vote 0 down vote accepted

It looks like the issue was with my Ethernet adapter, which is incompatible with OS X Mavericks. I just checked out its one-star reviews here: http://www.amazon.com/StarTech-com-Gigabit-Ethernet-Network-Adapter/product-reviews/B0095EFXMC/ref=cm_cr_dp_qt_hist_one?ie=UTF8&filterBy=addOneStar&showViewpoints=0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.