4

Found that it's a common problem that the 'Home' and 'End' keys don't function as-expected on MacOS. Found this fix, posted on LifeHacker:

http://lifehacker.com/225873/mac-switchers-tip--remap-the-home-and-end-keys

The issue is that this fix only works on native/Cocoa apps and doesn't work on many of the other apps like ThunderBird and Eclipse. Will be thankful for any help, regarding this.

PS: I frequently switch between the beginning and end of the line and this has been so annoying lately that I switch to a vim window to edit code and use Eclipse only for debugging it.

2

You can do this with Karabiner's 'Use PC Style Home/End #2'.
This remaps Home and End to ⌘← and ⌘→ respectively.

1

I have the wired keyboard for my iMac. All I have to do is hit the down arrow and it takes me to the end of the line I that my cursor is on. It works exactly like the "end" key on my old windows computers.

0

Found this AddOn, that solves this issue perfectly. It just remaps all key-shortcuts on ThunderBird to work as it works on other systems like Windows and Linux.

https://addons.mozilla.org/en-US/firefox/addon/keyfixer/

This is by-far the easiest and most effective method I could find.

0

Karabina is now Karabina-Elements. Download it and go to Complex Modifications:

enter image description here

Click Add Rule:

enter image description here

Click Import More Rules from the Internet, and select PC-Style Shortcuts:

enter image description here

Open the link with Karabina-Elements and click Import:

enter image description here

Enable these options (may as well make print screen work):

enter image description here

There is another option to use Ctrl+a and Ctrl+e for the terminal but I already fixed that like this (home/end are the diagonal arrows):

enter image description here

I also added the ctrl/shift-up/down shortcuts in there because for some insane reason Apple doesn't include them by default.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .