5

I have a dozen or so image files on my iMac's desktop. Most of the time, after booting up my computer, it displays a thumbnail of each image (as it should). But sometimes, the thumbnails won't show up (see screenshot below).

Screenshot

It appears to happen randomly. I estimate that it happens about 20% of the time.

Why is this, and how can I prevent it from happening? I am running OS X 10.9.4. Thanks.

  • Open your Console app. In the upper right corner, enter a search for com.apple.IconServicesAgent. Update your post, or supply a pastebin link in your reply with the 10 most recent entries, if applicable. – njboot Aug 27 '14 at 6:23
  • @njboot Thanks, here are the search results I got back. The problem occurred yesterday (8/26/14), but there don't seem to be any error messages for that day. Also, the earliest log entry is only 3 days old, which seems strange. pastebin.com/Wue07AH7 – Michael Aug 27 '14 at 23:39
2

Based on your log, I suggest trashing the Finder property list, then rebooting.

  • Open Terminal
  • Enter the following command rm ~/Library/Preferences/com.apple.finder.plist
  • Restart
  • If the issue persists, I suggest following these instructions. to completely reset the service.

Further information: The X Lab's Maverick's Post Installation Issues

  • 1
    Thanks. I've run the rm command. If the problem does not surface in a week or so, then I will consider it fixed. :) – Michael Aug 29 '14 at 0:28
  • Nope. It happened again. :( The rm command didn't work. I tried the longer set of instructions. We'll see if that works. – Michael Aug 30 '14 at 20:00
  • So, it seems to be working now. Marking as answered. Thanks again! :) – Michael Sep 5 '14 at 1:48
  • What other settings will this erase? – Tango Aug 17 '15 at 6:56
1

I just solved the same issue by going (in the Finder) to View->Show View Options. There, I moved the Icon Size slider to a larger size. All the image thumbnails loaded. Then I returned the slider to my selected size.

HTH!

1
  1. Right click: show view options
  2. Show icon preview: yes

enter image description here

1

OMG that linked gist did solve it! (from Apple forums).

Here is the bit that worked and fixed it:

  • mkdir ~/tmp-quicklook
  • mv /System/Library/LaunchAgents/com.apple.quicklook.* ~/tmp-quicklook/
  • Log out/Log in (or reboot)
  • sudo mv ~/tmp-quicklook/com.apple.quicklook.* /System/Library/LaunchAgents
  • Log out/log in (or reboot)

(the two "resets" are really necessary)

Still the folder preview doesn't work but looks like it's much harder to fix:

desktop

0

This was happening to some of my image files as thumbnails on the Desktop. I simply went to Force Quit and relaunched Finder. Images all returned to these thumbnails. Hope this helps s.o.

  • Welcome to Ask Different. It's helpful if you explain how to "Force Quit" an application for the visitors who are not familiar with that procedure. – Allan Jul 27 '16 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .