1

When I search something in Spotlight the top search result is highlighted by default (as it should be). However when I press the down arrow to select the next result, the top result remains highlighted no matter how many times I press the down arrow. The strange thing is that Spotlight responds as if the correct result was selected. For example:

After pressing cmd + Space and typing "android":

After pressing down arrow twice:

After pressing Enter Android Studio.app is opened, despite the fact that Spotlight hasn't updated the highlighting to show that Android Studio is selected.

I would like to know how to make Spotlight respond to pressing the down arrow by highlighting the correct result. I am running Mavericks 10.9.4 on a Mid 2010 13-inch Macbook Pro. I recently upgraded from Snow Leopard and Spotlight worked fine before. Thanks!

  • What you're seeing is not normal 10.9.4 behavior, as using the down-arrow works as expected for me. As a first try, perhaps repair permission using disk utility and let spotlight reindex (add your drive to the privacy settings (system preferences > spotlight), reboot, and remove it again) – Kevin Grabher Aug 26 '14 at 7:04
  • @Kevin you are a genius, I repaired permissions using disk utility and rebooted and now it works! Thank you! – Jason Pather Aug 26 '14 at 10:55

You must log in to answer this question.

Browse other questions tagged .