0

I tried fixing the issue of not being able to access LinkedLn by installing lots of certs from DigiCert in my Keychain and while that fixed LinkedIn, I then couldn't go to Github.com. I ended up having to restore my keychain from time machine, and for the /Library and /System/Library paths, I had to do the restore to a temp directory. THis only affects Safari and Chrome, and not Firefox.

Any way, I got my system back to accessing github, but LinkedIn still has the issue.

Is there any utility to properly check and fix SSL configuration issues on Mac OS X?

~/Library/Keychains
/Library/Keychains
/System/Library/Keychains 

Should I maybe just trust the linked in cert (or digicert one)?

Safari gives me options:

enter image description here

enter image description here

Firefox shows LinkedIn as fine: enter image description here

Next, digicert.com shows a SSL error on Chrome, but not on Safari: enter image description here

Even more oddly, when I click for more info from Chrome, the Cert shows as valid! enter image description here

1

I wouldn't start randomly trusting individual certificates for websites. That just sounds like a bad idea. Without the chain of trust to confirm the provenance of the certificates it just seems like too much of a risk.

One option is to visit DigiCert's site and download the specific DigiCert certificates that are missing and install them. You appear to still have the High Assurance EV Root CA certificate installed that the site uses, so you can be confident that you are downloading them from the proper source. Just download the file and open them, Keychain should launch and accept them.

https://www.digicert.com/digicert-root-certificates.htm

I'd also recommend running Keychain First Aid. You can find it on Keychain's application menu.

  • Keychain first aid said I have no issues. After I had installed all the downloads that digicert offers, I could no longer log into github.com – justingordon Aug 22 '14 at 3:07
0

I ran into a similar issue just the other day, only in Safari.

An HTTPS site kept popping up a list of certificates to click on and then continue or cancel, it never went through. What I found is that the certificate in the keychain was damaged, deleting those certs in the keychain utility fixed the issue.

BEFORE YOU DO THAT Backup your keychain, just in case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .