0

I'm tying to configure my IMAP mail account using Apple OSX Mail to behave in what would seem to be the obvious way: sent mail should appear in the special "Sent" mailbox, deleted in the "Trash", and junk in "Junk". Getting this to happen would seem to involve the "Mailbox Behaviors" settings associated with the account in Mail's preferences; but all my attempts result in bizarre behavior.

Focusing for the moment on just sent mail, and on my Outlook.com account, which I've named "MSN", here's what I get:

If I check "Store sent messages on the server" I get two copies of each message sent, both on the server in the "Sent" folder (as viewed through the Outlook.com web UI) and in OSX Mail in the "MSN" folder under "Sent" (correctly reflecting what's on the server). And to make things a bit weirder, only one of the copies displays the addressee's e-mail; the other just shows my (i.e. the sender's) name instead.

If I uncheck "Store sent messages on the server" I get one copy on the server in the "Sent" folder and and in the "MSN" folder under "Sent", and one in OSX Mail in a "Sent" folder that appears there under "MSN".

For reference sending from iOS behaves as expected: sent messages go into the special "Sent" folder on the iOS client and into the Sent folder on the server, and these messages appear once, in the "MSN" folder under "Sent" in OSX Mail, at least if "Store sent messages on the server" is checked there. But this means that if I uncheck "Store sent messages on the server" in OSX Mail, messages sent from iOS don't appear in OSX Mail's "MSN" folder under "Sent".

I can find no logic in this behavior at all. What settings should I use to get the (obvious) expected behavior: one copy of each sent message in the "MSN" under "Sent" in OSX Mail, and one copy in "Sent" on the server (ideally with friendly name recognized by the Outlook.com web UI)? Failing this, are there best practices for coping?

--

Note that the deleted messages and drafts seem to behave as expected when "Store sent messages on the server" is checked, it's only sent messages that produces this odd behavior.

Also: Drafts on iOS are stored in the special "Drafts" folder as expected, but don't appear at all on the server. Though there is a folder there called "Drafts" too, that only saves drafts from the Web UI or (suitably configured) from OSX Mail.

  • Note that I don't know whether this behavior is general to IMAP, or specific to outlook.com and would appreciate assistance with either (or both). – orome Aug 20 '14 at 13:18
  • This may be related to a question about "remapping" mailboxes in OSX Mail; but it's not clear how (e.g. what "mailbox behavior" I should choose) or what mailbox(es) I should "remap" (if any) to get the behavior I'm seeking. – orome Aug 20 '14 at 13:37
  • Update: I now see that the remapping mentioned in the comment above is equivalent, for server folder names expected by OSX Mail, to the "Store sent messages on the server" checkbox. So the question (and odd behavior remains): how do I avoid duplicates of every sent message? – orome Aug 20 '14 at 18:53
  • This is probably outlook.com sepcific, because i have 4 imap accounts activated, and haven't any duplicate messages. – jm666 Aug 20 '14 at 19:25
  • @jm666: Yes, it appears to be. I've experimented with other accounts and they seem to be better behaved. – orome Aug 20 '14 at 19:26

You must log in to answer this question.

Browse other questions tagged .