I've always used Mail in Mac OS X but one day I decided I would try Outlook 2011 so I could manage rules and filters without having to go to OWA. I was not very happy with Outlook 2011 so I removed it and decided to go back to Mail for Mac OS X. Since trying Outlook 2011, I'm having problems setting up the Exchange account in Mail.

My company uses [email protected] and [email protected] for our email address/alias.

When I setup the account, auto discovery finds everything just fine and logs me in and downloads all the mail, rules, filters, etc. stored on the server. The problem is in Internet Accounts in System Preferences, I now see two Exchange accounts. One for first.last@ and another for flast@

I didn't think too much about this since mail seemed to be working fine, but one day I noticed something when I did a reply all to a mail message. It included myself in the reply to fields. I thought maybe it was a setting in Mail that I overlooked when setting up the Exchange account. As it turns out though, the problem is that the first.last@ account is now somehow the default mail account on Exchange and the flast@ is what I'm replying with.

Checking System Preferences, I noticed that the first.last@ Exchange account doesn't have checks in the selection boxes for Mail, Contacts or Notes, but it does for Calendars and Reminders.


However the flast@ is exactly the opposite; it has checks in the selection boxes for Mail, Contacts and Notes, but not Calendars or Reminders.


When I try to enable Mail, Contacts or Notes in the first.last@ Exchange account I get an error dialog stating "There was a problem setting up the account. An unknown error occurred."

Unknown error

I do not experience this behavior on my iPhone 4S or my iPad Air.

I'm using Mac OS X Mavericks 10.9.4 and iCloud for my home accounts and connecting to an Exchange 2010 work account. Any information would be greatly appreciated.

Thank you.

1 Answer 1


chflags nohidden ~/library go to drive>users>XXXX>library>MAIL>V2>ACCOUNTS.plist edit the email address and save.

  • Thank you for your comment, Max. Unfortunately I don't work with that employer anymore and am unable to test and verify this as a fix.
    – user236557
    Commented Mar 18, 2016 at 18:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .