0

I'd like to switch the accessibility preference "Scroll with inertia" on and off for a Magic trackpad. The preference can be found in the accessibility preferences/Mouse and Trackpad/Trackpad Options/Scrolling "with/without inertia" (see here: http://de.tinypic.com/view.php?pic=2rw00wg&s=6#.U_NrJrx_ulA).

I think, that this preference resembles the key "TrackpadMomentumScroll" in either the com.apple.AppleMultitouchTrackpad or com.apple.driver.AppleBluetoothMultitouch.trackpad domain.

Using the defaults command doesn't seem to change the preference. At least, OS X doesn't react to the command and the preference in the GUI isn't reacting either.

I guess, I need to restart some daemon to apply the change.

Can somebody help me here?

Thanks.

Kind regards Dennis

0

Oh, found it. You'll have to reload the appropriate kernel extension like this:

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad TrackpadMomentumScroll -bool false

sudo bash -c "kextunload /System/Library/Extensions/AppleBluetoothMultitouch.kext; kextload /System/Library/Extensions/AppleBluetoothMultitouch.kext"

After that your trackpad will shortly become unavailable, but will be reconnected and have the MomentumScroll setting.

This still isn't, what the System Settings-App does, because you'll have to enter your password for sudo (and be an administrator), but still it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .