Specs: MacBook Pro 7,1, 2.4gHz Intel Core 2 Duo, 4GB DDR3 RAM, 500GB HDD with Snow Leopard v10.6.7

I'm having a weird problem. I want to boot from the install disk to run Disk Utility because I'm having a Time Machine problem (that's not the problem). So I grab the install disk and hold down C as the computer starts up. The logo appears and then it goes straight to the login screen. I did it again, still the same thing.

So I double check and saw that Startup disk is set to Snow Leopard disk and there is nothing plugging into the computer besides the power cable.

So I did it again, still went straight to the login screen. So I tried booting into safe mode by holding down shift key, still the same result. Also tried it with booting into the Hardware Test with the Application Disk, still booting straight into the login screen.

The computer itself works fine, in fact I'm typing with it. The DVD drive works because I just finished playing one of the West Wing DVD and the supplied Apple disks works and load setup just fine.

There have been no hardware modifications in the last 6 months.

Can anyone help with my weird problem please?

  • 1
    Is the EFI firmware password protection on?
    – user6124
    May 16, 2011 at 14:23

3 Answers 3


Press and Hold C button should take place immediately after you switch the MBP on. Delay could cause it to go with the normal boot sequence. Continue to hold until you see the gray screen with the apple on it


Try resetting the PRAM by holding down + + P + R during startup. What SHOULD happen is the machine will chime, the screen will go black and it will chime again. At this point, you can hold the C key and boot to the DVD. Let us know if this works or not.


I've heard of issues on some Macs seemingly ignoring the C key on boot. Try holding down . This will go into the boot menu, and will prevent the default OS from booting, even if nothing else is detected (i.e. external drives, such as optical media). From here you can see if the DVD is available to boot from.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .