1

I'm using OS X 10.9.4 and I have a Brother HL-1440 that I've been using for years, even before I was using an iMac. It's been a real workhorse and doesn't show signs of failure mechanically (it's still on just the 1st toner cartridge after the one included when I bought it). I've never had an issue with this printer working with OS X until about two weeks ago.

It looked like it was online and I ran a program on the Terminal that sent output to it. Nothing happened. It kept showing up as "Offline," but I couldn't find anything to tell me why. I finally looked around, found the Brother driver (probably the same as the one I had been using), downloaded and installed it, removed, power-cycled, then added the printer and it showed up again and I was able to use it.

A week later I was using it from the command line again and, again, it showed as "offline." I tried re-installing the driver, power-cycling, and the rest of that line of thinking, but now it doesn't show up at all.

I grabbed a different USB printer cable, hooked it up, connecting it to a different hub, and the printer just does not appear now. I can use either printer cable, but it's not there. I've tried using CUPS directly, through localhost:631, but it doesn't see it either.

I know it's been around a while, but it would surprise me if the electronics (which don't move) would give out before the mechanical parts show any sign of failing.

What can make a printer disappear that I might be able to fix? It seems like there's something flaky going on (and the USB info shows everything else shows up well, so it's not the port on the iMac). If I have to junk it and replace it, I can do that, but if I can get it to behave again, that'd be great.

What can I look at and check to see why it isn't communicating?

1

I fixed my printer by installing a new driver after deleting the Old printer in System Preferences.(just hit the "-" button.) Then Download and install this:

http://support.brother.com/g/b/downloadhowto.aspx?c=us&lang=en&prod=hl1440_all&os=132&dlid=dlf006958_000&flang=4&type3=79

After that, go to System Preferences and add ("+" button) the printer. If it doesn't show up, check that it is plugged in and turned on, switch it off & on or take out the USB cable & put it back. Then it will appear. Remember to set it as the Default printer.

  • Thanks, but I've done that several times along the way - replacing the drivers - and it made no difference. – Tango Oct 29 '14 at 0:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .