2

I have an MBP that is connected to the internet through ethernet. I've enabled internet sharing through wi-fi, my plan being to allow my iPad to connect to the internet through wi-fi.

I've created a wi-fi network and told my iPad to connect to it. When I do so I get a warning that the wi-fi network does not have an internet connection and if I force the connection my iPad cannot connect to the internet (duh).

How can I share the ethernet connection between my laptop and my iPad?

Update: Screenshot

  • 1
    please provide a screenshot of your network settings and internet sharing settings on the MBP. – Henrik Söderlund Aug 18 '14 at 14:12
  • I've added a screenshot. – ruipacheco Aug 18 '14 at 14:59
  • great. Looks fine so far. Have you tried disabling the firewall on the MBP and then trying to connect through the iPad? – Henrik Söderlund Aug 18 '14 at 15:20
  • Option 2 would be to check the IP address of the MBP's Ethernet connection. (Could posssibly be 192.168.1.5 or similar if connected to a router). Then compare this with the iPad IP address when connected to the MBP. If this IP addesss looks totally different then you might have to manually assign an IP address on the iPad to make it work. – Henrik Söderlund Aug 18 '14 at 15:22
  • Henrik-the IP of a machine using Internet Sharing (the iPad) should be on a different subnet than the machine providing the sharing (the MBPro). By default, OSX will put shared machines onto the 192.168.2.x subnet. So, you'd expect (and want) the machines to be on completely different subnets. – Scot Aug 18 '14 at 23:11
2

This is what you do:

  1. Make sure the ethernet cable is plugged in, and that the MBP is using ethernet to connect to the internet
  2. Open System Preferences and click on Sharing
  3. Tick the checkbox that says "Internet Sharing"
  4. From the drop down list, select Ethernet. Tick the WiFi (thanks Mateusz Szlosek) checkbox. It should look something like this: Sample Picture
  5. Click on Wifi Options, and configure your Internet Sharing network.
  6. On your iPad, connect to the network you created.

Be sure to verify that internet sharing is actually enabled by making sure the checkbox is ticked! enter image description here

Instructions are taken from these 2 websites, so if I'm not clear, please visit here and here.

  • I have no airport checkbox. – ruipacheco Aug 18 '14 at 14:35
  • On Mavericks it's now called Wi-Fi, just like on Your screenshot. – Mateusz Szlosek Aug 18 '14 at 14:42
  • In that case it's definitely not working. – ruipacheco Aug 18 '14 at 14:59
  • What do you mean by it's not working? – PoisonNinja Aug 18 '14 at 15:26
1

I'm also having the "not working" issue. I've had Internet Sharing work in the past but there has been a few times, like today, where I go in to the settings to start Internet Sharing (I use a modem dongle, so my Internet is not always up and running), the Wifi icon in the bar gets replaced by the Sharing icon for a half second, then it goes back to just being Wifi and starts scanning for Wifi connections. It's pretty frustrating, the data signal out here is weak on my phone so I'd like to be able for my phone to use the dongle via Wifi. It worked before.

I was unable figure out what changed from yesterday to today, other than my MBP going to sleep over night. The good news is a reboot fixed my issue so perhaps this is something that can get wedged and needs a reboot to recover from the failure.

  • Edit: Restarting my MBP worked to fix it. No issues using Internet Sharing after the restart. – Lshirt Aug 21 '14 at 8:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .